Can't see secure services in ArcGIS Explorer Desktop

3367
6
Jump to solution
06-01-2015 06:59 AM
deleted-user-BAik00wdZwPa
New Contributor II

We publish some of our map services to an on premise ArcGIS Server (10.2.2). Some of these services are secure and some are not. When adding this server to ArcGIS Explorer Desktop (both 2500 and 2505), I can only see the unsecured services even when I use my server username/password that is used when accessing the same secure services through ArcCatalog.

I've tried adding the GIS server using all of the following combinations with no success. I can only see our unsecured services.

http://yourserver.com/arcgis/services

http://yourserver.com/arcgis/rest/services

http://yourserver.com/arcgis/admin/services

http://yourserver.com/arcgis/admin/rest/services

http://yourserver.com:6080/arcgis/services

http://yourserver.com:6080/arcgis/rest/services

http://yourserver.com:6080/arcgis/admin/services

http://yourserver.com:6080/arcgis/admin/rest/services

Is this even possible to see/add secure services in ArcGIS Explorer Desktop 2500/2505?

1 Solution

Accepted Solutions
JoeFlannery
Regular Contributor II

Mathew:

Go to your REST service directory in a browser and sign in.

Find your map service of interest and click on it to see the REST page for this service.

For "View In:"  choose "ArcGIS Explorer"

AGX.JPG

When you click this link, you will be able to download an NMF file with this map service in the table of contents.  Download the file, double-click it to open it.  You will be challenged for a UN/PW.  Add a UN/PW and the map will open with you map service.  You can now "Share" the map service with other AGX users by right-clicking and choosing Share as an NMC file or share the map with others.  Be sure to set check ON the Write authentication information for secure service into the map document  in "Map Properties" | "Data Access"

View solution in original post

6 Replies
Russellchapman
New Contributor III

Hey matthew,

You might try adding an "s" to the http part of the url.....  ie https://yourserver.com/arcgis/services

to enable a secure server connection?

0 Kudos
deleted-user-BAik00wdZwPa
New Contributor II

Thanks for the suggestion Russell.

I tried adding an “s” to the “http” in the server URL but I still can’t see the secure services.

0 Kudos
JoeFlannery
Regular Contributor II

Mathew:

Go to your REST service directory in a browser and sign in.

Find your map service of interest and click on it to see the REST page for this service.

For "View In:"  choose "ArcGIS Explorer"

AGX.JPG

When you click this link, you will be able to download an NMF file with this map service in the table of contents.  Download the file, double-click it to open it.  You will be challenged for a UN/PW.  Add a UN/PW and the map will open with you map service.  You can now "Share" the map service with other AGX users by right-clicking and choosing Share as an NMC file or share the map with others.  Be sure to set check ON the Write authentication information for secure service into the map document  in "Map Properties" | "Data Access"

View solution in original post

deleted-user-BAik00wdZwPa
New Contributor II

Thank-you Joe!

Your workflow and walkthrough worked for me. I’m little disappointed that Esri doesn’t have a more straightforward way of adding these services to ArcGIS Explorer Desktop, but this process will get us what we need.

Thanks!

0 Kudos
JoeFlannery
Regular Contributor II

Mathew:

AGX 2500/2505 is so old and so far behind the rest of ArcGIS software and technologies - I hope whatever Esri has prepared as the next version takes care of the shortcomings of what we are currently using.

Take care.

0 Kudos
BrendanBladdick3
Esri Contributor

I experienced the same difficulty. I don't think ArcGIS Explorer can use services when adding the service using the web adaptor. I added my server (which is not publically accessible) to ArcGIS Explorer twice, it the exact same server but one is using the web adaptor and the other is bypassing it.

 

 

Now they are both added and can connect and I can even see my layers on the list but when I add it to the map from my web adaptor URL then it adds but doesn't show up.

 

However when bypassing the web adaptor and using 6080 with the fully qualified domain name with "/ArcGIS/Services" at the end, my layers show up on map. Hopefully this will help.