Search widget case sensitivity causing selected points to flicker attributes

558
3
Jump to solution
05-25-2022 12:30 PM
MackenzieCope
New Contributor III

I am using Experience Builder to create a rockhounding locations guide. I have it set up where if you select a point on the map, it will display the point's attributes in a column on the side. (It is just some text boxes with certain phrases connected to the data to bring in the attributes). 

I've added a search bar to search the data for specific rock/mineral/fossil types and it will filter the data on the map just fine, but the data points that don't EXACTLY match the upper/lower case are no longer selectable and won't show attributes on the side. It will flicker the attributes in the sidebar but go away quickly. I made sure to have the "exact match" on the search settings unchecked, but this still occurs.

The only action/trigger I have set up is on the search widget to zoom to the search results. Deleting this action/trigger still leaves the non-matching points unselectable.

It's a similar issue to this one: https://community.esri.com/t5/arcgis-experience-builder-questions/search-list-and-search-widget-bug/... but I don't have any actions or triggers set up in the side column showing attributes that may be interfering.

Here's my experience link:
https://experience.arcgis.com/experience/195815b458914fa69c9f1e45678a972a

You can use the phrase "pyrite" to test the search functionality on the case sensitivity.

Any ideas on how to fix this case sensitivity issue with the search function? Thanks!

0 Kudos
1 Solution

Accepted Solutions
ShengdiZhang
Esri Regular Contributor

Hi @MackenzieCope ,

This is a known issue and we plan to fix it in the next release.

Thanks,

Shengdi

View solution in original post

0 Kudos
3 Replies
ShengdiZhang
Esri Regular Contributor

Hi @MackenzieCope ,

This is a known issue and we plan to fix it in the next release.

Thanks,

Shengdi

0 Kudos
MackenzieCope
New Contributor III

Hi @ShengdiZhang ,

Thanks for the info! Looking forward to the fix! 🙂

I appreciate your reply,

Mackenzie Cope

0 Kudos
ShengdiZhang
Esri Regular Contributor

Hi, this bug should be fixed in today's update, please give it a try.

0 Kudos