Search in list widget not working

377
5
Jump to solution
11-07-2021 06:38 PM
elpinguino
Occasional Contributor II

Hi ExB community,

I've been using the search function in the list widget. It has been working well for me.

I've changed some data in the layer that connects to the list widget, and now when I use its search function, it doesn't filter or show possible options.

I thought I had reconnected everything up.

Has anyone else had this issue or possibly I've missed something obvious?

Thanks in advance for your help.

elpinguino_0-1636339030871.png

elpinguino_1-1636339053274.png

elpinguino_2-1636339074434.png

 

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
elpinguino
Occasional Contributor II

@ShengdiZhang solved this. One of the fields "Use" was selected for Searchable fields. This may be a restricted word, so once I disabled this, the search went back to its normal self. Thanks again for the quick action!

View solution in original post

5 Replies
ShengdiZhang
Esri Contributor

Hi @elpinguino ,

Are you unable to configure the list search field, or does the list search tool not work as expected at run time?

In the latter case, you now need to type at least 3 characters to get suggestions, which is the consistent behavior of ArcGIS online products.

Regards,

Shengdi

0 Kudos
elpinguino
Occasional Contributor II

@ShengdiZhang It's not working at run time. It wasn't working from this afternoon. Previously it has always worked for me. 

The only differences today are that I've changed the format from listing sideways to up and down. I've also changed the view to have a filter on it.

 

Video of the issue 

0 Kudos
ShengdiZhang
Esri Contributor

Hi, I cannot reproduce your issue. Would you mind sharing your app with me? My user name is she10946. Alternatively, you can submit an issue through Support.

0 Kudos
elpinguino
Occasional Contributor II

@ShengdiZhang I've shared it with you now. Let me know if you have any issues.

0 Kudos
elpinguino
Occasional Contributor II

@ShengdiZhang solved this. One of the fields "Use" was selected for Searchable fields. This may be a restricted word, so once I disabled this, the search went back to its normal self. Thanks again for the quick action!