Select to view content in your preferred language

Query widget: Highlighted features remain after reset of query

794
6
02-18-2022 12:06 PM
JohnSasso2
Occasional Contributor

A problem with the Query widget I am seeing with various feature layers (regardless of geometry).
I issue a query, then do Show on Map to go to the selected features.  Then, when I click on the garbage can and reset the query, the highlight of the features remains.  Below is an example, showing the highlight of the selected polylines, even though the underlying feature layer is turned off.  I have to refresh my browser for the highlight to go away

JohnSasso2_0-1645214472171.png

 

0 Kudos
6 Replies
SophiaUthe
New Contributor II

Hi John, did you ever figure out how to solve the problem?

Thanks,

Sophie

0 Kudos
USLEOperations
New Contributor III

No, unfortunately, and the problem still exists in EB 1.9. 

And its unfortunate that Esri's EB team has not responded to this.  Not good.

0 Kudos
Tiff
by
Occasional Contributor III

I am seeing this same issue for my spatial query results. There is no way to turn off or reset this without refreshing the browser. Is this still an issue for you as well?

0 Kudos
TonghuiMing
Esri Regular Contributor

After the Show on Map results are populated inside the map, it can be removed from the map:

TonghuiMing_0-1694143450716.png

 

USLEOperations
New Contributor III

Yes, I confirmed the bug is fixed in EB 1.11

ChrisMyers_NewQuest
Occasional Contributor

THANK YOU!!!

0 Kudos