Select to view content in your preferred language

Filter widget doesn't work with (all) spatial data

1141
4
Jump to solution
06-10-2022 05:01 AM
Labels (1)
Valentin
New Contributor III

Hello everyone,

 

I'm new to Experience Builder and i'm facing an issue which cost me some hours sadly. 

I wanted to have a simple filter widget which filter data on a map. I added a table widget which display filtered data. My first data is just a simple feature layer and everything works so no worries on this side.

But for my other features layers, the filter widget doesn't filter any data on the map. On the other hand, the table widget displayed all the filtered data. So, clearly there is an issue with the link between my filter widget and the map for some data. 

The main data is a Web Map which contains multiple Web Services with multiple Layer Group inside. Is there any problem with this structure ? And do yo guys have any ideas to my ideas ?

Any ideas could help 🙂

0 Kudos
1 Solution

Accepted Solutions
Valentin
New Contributor III

Anyway, i was facing with not a lack of knowlegde but with a bug. In fact a similar topic can be found here : https://community.esri.com/t5/arcgis-experience-builder-questions/default-filter-in-data-not-work-on... 

which is related to this main topic here : https://community.esri.com/t5/arcgis-experience-builder-questions/filter-widget-not-working-in-map/m...

So if your filter widget doesn't filter all datas on your map, download the patch 1 for the 1.8 version : https://github.com/Esri/arcgis-experience-builder-sdk-resources/tree/master/patches/1.8/patch1/arcgi... 

 

Problem solves, i close the subject

View solution in original post

4 Replies
QuantitativeFuturist
Occasional Contributor

You need to configure your actions from the source widget (filter) to the destination widget (map) but you need to configure it for each data source. You should probably take an experience builder course because this is fundamental to app design.

Valentin
New Contributor III

Thanks for your advices. Unfortunately all my filter were linked to the map. But one of my collegue said that our web service publication doesn't work correctly, so i couldn't access to all features data. Moreover our server are down so i couldn't do anything ahah.

0 Kudos
Valentin
New Contributor III

In fact, all datas cannot be filtered because there are in web service, otherwise everything works. So does the filter widget accept feature layer from web service ?

0 Kudos
Valentin
New Contributor III

Anyway, i was facing with not a lack of knowlegde but with a bug. In fact a similar topic can be found here : https://community.esri.com/t5/arcgis-experience-builder-questions/default-filter-in-data-not-work-on... 

which is related to this main topic here : https://community.esri.com/t5/arcgis-experience-builder-questions/filter-widget-not-working-in-map/m...

So if your filter widget doesn't filter all datas on your map, download the patch 1 for the 1.8 version : https://github.com/Esri/arcgis-experience-builder-sdk-resources/tree/master/patches/1.8/patch1/arcgi... 

 

Problem solves, i close the subject