Can't select features in grouped layers

277
7
04-07-2022 05:58 AM
Labels (1)
sarahc_WellingtonCounty
New Contributor II

I'm creating an app with Experience Builder. The app is using a map that I created with the new map viewer and I have turned on pop-ups for my layers. I have 6 layers in the map, 4 of which were combined into a group layer to keep my map layers organized. 

I'm experiencing an issue where I can't select any features in the layers that are part of the group. 

I have feature info windows that are set up to show details of a feature that is selected. This works as expected for the two ungrouped layers in my map. However, I am unable to select features from a layer that is in the group. If I move the layer out of the group, I can select a feature and the feature info window filters correctly. As soon as I move the layer back into the group, selecting features no longer works. 

Is this expected behaviour or is this a bug with Experience Builder? Ideally I would like to use the group layers rather than having all of the map layers individually listed in the layer list. 

Thanks for the help in advance!

0 Kudos
7 Replies
ABishop
Regular Contributor III

Hello Sarah,

This may seem like a dumb question, but how are you selecting the features?  

Amanda Bishop, GISP
0 Kudos
sarahc_WellingtonCounty
New Contributor II

I'm selecting the features by clicking directly on the map. It works fine for any layers that are individually listed in the layer list (not grouped), but it stops working any time layers are in a group. 

I've done a bunch of tests with each of my layers - drag them into a group, selecting/clicking on features stops working - drag them back out of the group and selection works again. 

Super odd! This seems to only happen in Experience Builder. I can create other apps (instant apps, dashboards) and selecting features from a grouped layer works totally fine. 

ABishop
Regular Contributor III

Try adding a custom selection widget to select features and see if this works.  If not, I would check the bug report online or contact ESRI customer support.

Amanda Bishop, GISP
0 Kudos
sarahc_WellingtonCounty
New Contributor II

Thanks for the suggestions! 

I just did a quick test, and using a list widget to select features from a grouped layer does work. However, its not an ideal solution for the app I'm creating. I'm working with a zoning layer and there are way too many features to use a list for selection. For this app, I need the users to be able to click directly on the map. 

I'll head over to the bug reports and see what I can find there. Thanks again!

ABishop
Regular Contributor III

You're welcome! 

Amanda Bishop, GISP
0 Kudos
JenniferHinojosa1
New Contributor

any updates? I'm having the same issue as well. 

0 Kudos
TonghuiMing
Esri Regular Contributor

@sarahc_WellingtonCounty Are you still seeing this issue? It seems to me that in the screenshot, you had the entire group visibility turned off:

TonghuiMing_0-1657613099133.png

 

0 Kudos