Attempted to Install Experience Builder - Developer v1.2 : failed at npm

468
5
Jump to solution
01-14-2021 05:32 PM
DavidMurray_ODWC
New Contributor III

I was tempted to poke around the Developers section of ArcGIS, in the hopes of perhaps fingaling my way to a widget that behaved the way I wanted it to.

DavidMurray1_0-1610673078431.png

The requirements included your own installation of the ExB Developer Edition ~for which there is a handy video that purports to 'walk the viewer through the installation steps.'  There's a bit of a gap in the instructions 37 seconds in. 

DavidMurray1_1-1610673370620.png   But I was able to download & install nodejs, and the various "necessary tools" for its use, including "Chocolatey."

DavidMurray1_2-1610673391481.png

 

 

 

 

 

 

 

 

 

I have opened cmd prompts to "clean install" the client and server, but typing npm ci does nothing.

npm ci not working as indicated.PNG

 So, I'm stuck on Step #8 of installing the Developer Edition.

Any ideas re: how to proceed? 

This is probably a rookie mistake, and we'll all have a good laugh later, but I'm no where near starting the 15 minute 'Create a starter widget' tutorial.

 

 

0 Kudos
2 Solutions

Accepted Solutions
DavidMartinez
Esri Regular Contributor

Hey David,

What version of node do you have installed? 

 

 

View solution in original post

0 Kudos
DavidMurray_ODWC
New Contributor III

It was, as I'd supposed, a newbie error.  And it was your question that led me to the solution.

The failing cmd window printed:

Need to pay attentionNeed to pay attention

...clearly showing that it was trying to find nodejs in C:\Program Files (x86)\ and version 1.3.2

When I'd downloaded the newest version into C:\Program Files\

So I renamed the original nodejs folder to nodejs_old, and reinstalled the nodejs to the x86 folder.  
Step #8 now works without a hitch.

View solution in original post

0 Kudos
5 Replies
DavidMartinez
Esri Regular Contributor

Hey David,

What version of node do you have installed? 

 

 

View solution in original post

0 Kudos
DavidMurray_ODWC
New Contributor III
0 Kudos
DavidMurray_ODWC
New Contributor III

It was, as I'd supposed, a newbie error.  And it was your question that led me to the solution.

The failing cmd window printed:

Need to pay attentionNeed to pay attention

...clearly showing that it was trying to find nodejs in C:\Program Files (x86)\ and version 1.3.2

When I'd downloaded the newest version into C:\Program Files\

So I renamed the original nodejs folder to nodejs_old, and reinstalled the nodejs to the x86 folder.  
Step #8 now works without a hitch.

View solution in original post

0 Kudos
DavidMartinez
Esri Regular Contributor

Hi David,

 

Glad you got it working.

 

Cheers,

 

David 

0 Kudos
JohnL
by
New Contributor II

Can you try just install Node.js default option (not select like Chocolatey)? and run npm comments as administrator.

0 Kudos