When initially trying to create site for the first time within ArcGIS Server Manager I am getting the error message "Failed to create the site. Failed to create the service System/PublishingToolsEx.GPServer" ...???

4628
13
Jump to solution
02-08-2017 12:00 PM
AndrewPfeiffer
New Contributor II

posted an attachment of the error message..

0 Kudos
1 Solution

Accepted Solutions
AndrewPfeiffer
New Contributor II

Hey Julien, 

Yes, i was able to figure it out.. with the help of esri phone support.  I had a good version of chrome, except i only had IE8, ArcGIS needs 9 or up. So, download IE11, and make sure you have active scripting enabled if youre using server manager in IE.... Internet Options (Security Tab > Custom Level > Scripting > Active Scripting > Enable). Enable it in chrome as well for good measure

View solution in original post

13 Replies
DerekLaw
Esri Community Moderator
0 Kudos
AndrewPfeiffer
New Contributor II

I tried both these fixes, but again my problem lies with PublishingToolsEx and not CachingTools

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Make sure the ArcGIS Server account and Current User account have permission to read configuration store (config-store) and server directories (directories) folders. Restart ArcGIS Server service (services.msc).

By the way, what version of ArcGIS Server are you using.



Think Location
0 Kudos
AndrewPfeiffer
New Contributor II

Double checked folder permissions and restarted the ArcGIS service. I'm running enterprise 10.5 with ArcGIS and GeoEvent server on a windows 2008 R2 SP1 VM. I have no mention of PublishingToolsEx.GPServer in C:\ArcGISServer\config-store\services\System, but it did create the PublishingToolsEx.GPServer folder in C:\ArcGISServer\directories\arcgisoutput\System

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

It would be wise to contact your Esri Tech Support representative to check the environment and provide an appropriate solution.



Think Location
0 Kudos
JulienLongchamp
New Contributor

Hello, 

Any news on that ?

I have exactly the same problem.

 

Thanks

0 Kudos
AndrewPfeiffer
New Contributor II

Hey Julien, 

Yes, i was able to figure it out.. with the help of esri phone support.  I had a good version of chrome, except i only had IE8, ArcGIS needs 9 or up. So, download IE11, and make sure you have active scripting enabled if youre using server manager in IE.... Internet Options (Security Tab > Custom Level > Scripting > Active Scripting > Enable). Enable it in chrome as well for good measure

JulienLongchamp
New Contributor

Thank you Andrew ! 

I had IE8, go on IE11 and now it's working.

JayantaPoddar
MVP Esteemed Contributor

Hey Andrew,

Thank you for sharing the solution with us. You may mark your answer as correct so that the thread could be closed.



Think Location
0 Kudos