Unable to process request. java.io.IOException: An existing connection was forcibly closed by the remote host Rest

1540
3
02-14-2020 05:31 AM
ThomasIllingworth
New Contributor III

Good Afternoon Everyone


We have two joined ArcGIS server machines running 10.6.1 respectively. We have fully deployed the joined servers in our live environment and have started populating them with web services. I have noticed that when using the services for awhile now we have been receiving the following errors


WARNING 14 Feb 2020 12:55:33 Unable to process request. java.io.IOException: An existing connection was forcibly closed by the remote host Rest
WARNING 14 Feb 2020 12:55:25 Unable to process request. java.io.IOException: An existing connection was forcibly closed by the remote host Rest
WARNING 14 Feb 2020 12:55:19 Unable to process request. java.io.IOException: An existing connection was forcibly closed by the remote host Rest
WARNING 14 Feb 2020 12:55:11 Unable to process request. java.io.IOException: An existing connection was forcibly closed by the remote host Rest


When I was trying to use a web service which was a fairly simple layer the following errors were coming back and the layer was not drawing which has happened occasionally however I've been noticing it more recently 


I've had a quick look around everything appears to be working okay from what i can not quite sure where to look

We are also occasionally getting the below error as well

14 Feb 2020 08:42:19 Unable to process request. Extension not found Rest

Any suggestions on where to possibly look would be much appreciated

Thanks

Tom

3 Replies
LeeBrannon1
New Contributor III

I don't have an answer to this issue, sorry, but I am getting the same error messages in my server log, and would like to figure out the cause.

0 Kudos
ThomasJones1
Esri Contributor

Hello Thomas Illingworth‌,

Unfortunately the error message you referenced is fairly generic. The error message tells us a connection was established between client and server. Then at some point after the connection was established the connection was closed. 

Troubleshooting Suggestions:

  • Do these errors occur for a specific service?
  • How is the service being used when the error message is generated (e.g. query)?
  • What is the request path from the client to the server (e.g. DNS, FQDN, Web Server, Proxy).

For example if the service is being accessed over a web adaptor hosted on IIS. I would recommend reviewing the IIS logs for error messages that closely match the timestamp for the ArcGIS Server error messages.

Hope this helps!

Thanks,

Thomas.

0 Kudos
ThomasIllingworth
New Contributor III

Hello Thomas Jones

Thanks for getting back to me regarding the above question, yeah alot of the people I have spoken to have mentioned similar to what you have said about it being a generic error message

In terms of the trouble shooting suggestions you mentioned :

  • It never gives us which service it has come from just giving us that the source is from rest unfortunately 
  • Not sure what is happening at the time of error we have a combination of services most of them are read only with some feature server ones mixed in. I've had it happen to me when I was just panning around the map once.
  • It will be using dns to the best of my knowledge e.g test.***.gov.uk/arcgis/rest/services we are doing this through a third party load balancer and not using the  web adaptor. The system as a whole is working with this error popping up intermittently 

Do you think it is worth up the logging level?

My worry is that a connection could be closed if it is midway through a process of doing something 

Hope your doing well

Thanks

Thomas

0 Kudos