Replica management on Feature Servers

3899
2
08-11-2015 10:54 AM
GeorgeOulton1
New Contributor III

We currently have ArcGIS server 10.3, with mainly 10.2 SDE Postgresql Geodatases. We have been having intermittent issues with both syncing from Collector and online edits via a web map. When I investigated server logs the main ones that stand out are below:

Replica with GUID ({4CDDAFFA-9D50-4F40-8DEC-F93ECC7710A4}) does not exists on the server.

Error executing tool. SyncFeatureServiceReplica Job ID: jbd7f46b74b1444289677fe34824291a6 : ErrorMsg@SyncGPService:{"code":400,"infos":[],"description":"Replica with this GUID does not exist on the server"} Failed to execute (Sync Feature Service Replica).

Error: The current version does not support editing (base, consistent, or closed) [An open transaction was detected. All user transactions must be closed prior to StartEditing.].

I am suspecting that these errors may also stem from non-versioned data.

In the replicas REST endpoint there are many replicas for each FeatureServer and mutiples for each user. Is this normal or could it be an issue?

Are there any best practices or tips for managing(registering and unregistering) replicas for Collector?

Any insight on this would be greatly appreciated.

Thanks,

George

0 Kudos
2 Replies
WaylonLang
New Contributor II

I know this was quite awhile ago but did you ever find a resolution to this problem? We're getting the same error in the exact same circumstances as you with non-versioned data.

Thanks,

Waylon

0 Kudos
JarrettGreen
New Contributor III

We are having issues syncing back to our AGS, but not because it can't find the replica.  We are using versioned data and I can only find documentation on managing the verisons, not the replicas.  We have multiple replicas per user and wondering if anyone has guidance on any back-end management of these.

0 Kudos