"Feature service requires a registered database" error

7912
8
Jump to solution
12-23-2014 07:07 AM
SteveBurdette
Occasional Contributor

I have ArcGIS Server 10.2 running on a Windows Server 2012 R2 Standard server with SQL Server 2012 R2.  I'm able to create enterprise geodatabases fine, and import feature classes into the geodatabases with no problems.  I've registered the geodatabase with the server successfully.  I then created a map (with the geodatabase as the default database) and added a few of the feature classes in order to publish them as a service.

 

When I try to publish the service, the Analyze step in the Service Editor is returning a "Feature service requires a registered database" error.  I open up the data store registration page, choose Validate All, and everything checks out fine.  The map is using the same connection to the database that ArcMap Catalog uses, with a SQL Server login that is a dbowner of the database.  Is there anything that I'm missing here?  Have not been able to solve this issue.

0 Kudos
1 Solution

Accepted Solutions
JakeSkinner
Esri Esteemed Contributor

Try recreating the data store again.  Be sure you are using the same data connection that the data in ArcMap is added from.  If the user's were to be different, this would be considered a different data store.  For example, if I created the data store connected a user 'DBOUSER1', but the data is added to ArcMap using 'DBOUSER2', you would receive the error you mentioned.

View solution in original post

8 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Steve,

Make sure the arcgis server account has read/write privileges to the data you are trying to publish.  To make things easier, I usually grant the arcgis server account user 'sys admin' privileges for SQL Server instance.

If the database and ArcGIS Server are installed on separate machines, you will need to create the arcgis server account on the database server with the same username and password.

Below is a helpful link.  See the section 'Granting permissions to data in a database':

ArcGIS Help (10.2, 10.2.1, and 10.2.2)

0 Kudos
SteveBurdette
Occasional Contributor

Thanks Jake.  I added the local arcgis server account to the SQL Server database, assigned it the "serveradmin" and "sysadmin" roles, and mapped it to the geodatabase as a dbowner of the database.  Restarted the ESRI server service and restarted the database, and am still seeing the same error. I went through the help topic and everything looks good (am using SQL Server authentication and have checked "save user/password" in the connection properties). 

If you think of any other ideas I would welcome them...thanks again.

0 Kudos
StevenGraf1
Regular Contributor

How many servers do you have deployed and what is on what server?

You may need to go in properties of your instance --> Conenctions --> Make sure Allow Remote Connections to this server is checked.

Steven

0 Kudos
StevenGraf1
Regular Contributor

Also go into Sql Server Config Manager and make sure Protocols for InstanceName --> TCP/IP is Enabled.

0 Kudos
SteveBurdette
Occasional Contributor

Thanks for the reply Steven...both of these features looked good on the server.

0 Kudos
JakeSkinner
Esri Esteemed Contributor

Try recreating the data store again.  Be sure you are using the same data connection that the data in ArcMap is added from.  If the user's were to be different, this would be considered a different data store.  For example, if I created the data store connected a user 'DBOUSER1', but the data is added to ArcMap using 'DBOUSER2', you would receive the error you mentioned.

View solution in original post

SteveBurdette
Occasional Contributor

Jake,

That solved the problem.  I had originally created the database using an OS user and then had the ArcCatalog database connection using the SQL Server login.  I recreated the enterprise geodatabase using the SQL Server login and am not getting the error anymore during the Analysis phase of the service publish.

Thanks,

Steve

RyanTaylor10
New Contributor II

Thanks. Helpful.

0 Kudos