Is it possible to move services in ArcGIS for Server from the root into a folder?

6035
6
Jump to solution
12-08-2016 07:28 AM
EricHeinrichs
Occasional Contributor

We are using 10.3.1, but we are upgrading to 10.5 once the full release is out, if that makes a difference.

We have all of our services sitting in the root folder on the server, and I was wondering if it was possible to move them into other folders without deleting or recreating them. It's messy, and I am taking over from someone else that didn't put a lot of thought into the creation of services.

If not, what would be the correct course of action to make these changes? Or is the only way to do this is to delete the services and republish them into the desired folders?

Thanks!

1 Solution

Accepted Solutions
JayantaPoddar
MVP Esteemed Contributor

You should take a backup of the config-store before trying the following workflow.

1. Stop the service of ArcGIS Server (services.msc)

2. Navigate to <Install Drive>\arcgisserver\config-store\services. Locate the folder with the name of the service that you want to copy (*.mapserver)

3. Copy the desired *.mapserver folder and navigate to the desired Folder (inside ...config-store\services). Paste it.

4. Restart the service for ArcGIS Server (services.msc)

Check if the service has moved and running successfully from REST URL or from ArcGIS Server Manager.



Think Location

View solution in original post

6 Replies
JayantaPoddar
MVP Esteemed Contributor

You should take a backup of the config-store before trying the following workflow.

1. Stop the service of ArcGIS Server (services.msc)

2. Navigate to <Install Drive>\arcgisserver\config-store\services. Locate the folder with the name of the service that you want to copy (*.mapserver)

3. Copy the desired *.mapserver folder and navigate to the desired Folder (inside ...config-store\services). Paste it.

4. Restart the service for ArcGIS Server (services.msc)

Check if the service has moved and running successfully from REST URL or from ArcGIS Server Manager.



Think Location
AdamZiegler1
Esri Contributor

Just an additional note on moving services in ArcGIS Server. Moving a service in ArcGIS Server (unlike ArcGIS Online) affects the URL of the REST endpoint. So, if you have applications or users accessing the service they will all need to be updated with the new URL.

Adam Z

DylanKennard1
New Contributor II

This didn't work well in ArcServer 10.5.  Services get stuck in limbo. Finally got error saying service cannot start due to someone else using it. Rogue locks found and were cleared still nothing (with ArcServer Serive turned off).  Error log is not logging anything either.  Anyone have luck recently with 10.5 on Windows Server 2016?

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Not saying that this is the issue, but Windows Server 2016 is not on the system requirement list

ArcGIS Server 10.5 system requirements—Installation Guides (10.5) | ArcGIS Enterprise 

My guess is not many have tried.

0 Kudos
DylanKennard1
New Contributor II

Yeah I know : ( We have pushed 2016 pretty hard though and it works great with 10.5. I have a script to rebuild all the services but wanted to try it a different way.  I'll chalk it up as good test and would not encourage other to try this. in a production environment.  This is test environment so we thought what the heck right!

RebeccaStrauch__GISP
MVP Esteemed Contributor

This tool GitHub - eea/discomap.ServiceTransferTool: Transfer tool  has an option to change the folder.  I have not done that, but I have been testing this tool for transfering services from 10.2.2 o 10.4.1 to the same folder, so my guess is the other works too.  I hope to test on 10.5.x soon too (trying to install the pre-rel to test).

I did have to make a couple changes to the tool to get it to run for me.  And I've made quite a few other modifications for our purposes. 

Some other posts that might be helpful

Move/Copy Services to another Service Directory 

https://community.esri.com/thread/70787?commentID=647866#comment-647866  (goes to my post on tweaks I made to get OTB Transfer tool to run)