Is ArcGIS Server license 10.1-10.4 backward compatible with version 10.0?

2010
5
05-23-2016 12:08 PM
saileshkumar
New Contributor II

Is ArcGIS Server license 10.1-10.4 backward compatible with version 10.0? Wondering if there is any change in Server Product licensing in addition to Architectural change. There is no mention in the esri documentation except ArcGIS License Manager is (backward) compatible with ArcGIS 10.x, 10.0, and all 9.x products.

0 Kudos
5 Replies
RebeccaStrauch__GISP
MVP Esteemed Contributor

I'm not exactly sure what you mean as backwards compatible...a lot changed at 10.1, but is you are looking just at the licensing/authorization sides of things, I would say "yes". If you look at your myEsri page, it clearly shows two lines for 10.0 vs 10.1-10.4 in the "authorizes" section.

0 Kudos
HeatherHerrmann2
Occasional Contributor

It is compatible with 10.  Here is more information on it.

License manager installation and startup—Help | ArcGIS for Desktop

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Heather, I believe that is just for Desktop/Pro...sailesh kumar was asking about Server.

0 Kudos
saileshkumar
New Contributor II

Dear Rebecca,

Here I’m looking at backward compatibility of ArcGIS Server License 10.x with ArcGIS Server product 10.0. Throw error “Incompatible license version”

However the 10.4 licenses served from the 10.4 License Manager work for either the 10.x, 10.0, or 9.x client ArcGIS for Desktop software.

I’ve also noticed change in license keycode structure in 10.x vs 10.0, theY have included fulfilment ID.

Example:-

arcgisserver,101,ecp123456789,15-oct-2000,1JPJJE2E0CJS6Y0DF197,630C6C66DCC2A7EE18BEC407A7141F99CBC02760381170A17DCE90D3D4E4B14FD07EF6775C48F64099FEEF3FBB9FF0242BAB85A2614AF217C34821A360D4577A4750A2CDD44AF968B98A0EA26E98DC3ACAB0581F92B664976DECB90C704B7AEF483285AFE8609464622B48C33BB4394627E01B7C1F3A6DAA1E1C1C0E22893A74,FID__4c23b061_1336335a210__1c27

ArcGIS Server 10.0 Structure

arcgisserver,100,ecp123456789,15-oct-2000,S080YPJ0A58SLAMEY192

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Hi Sailesh, was that just a comment, or was there another question?  Have you tried using the 10.1-10.4 code with a 10.0 install and, and if so, are you getting an error?  Were you license back at 10.0?

If not, and you are trying to test something in 10.0, I would talk to your customer service rep or local distributor (or tech support) to see if there is a way you can test something on 10.0 (if you don't have the 10.0 authorization).

I know for use, although it looks like we have both 10.0 AND 10.1-10.4, we only have one license, so it's really an "OR" not an "AND".  (other than thru EDN--esri developer network---licensing).

Is there are reason you are trying to go back to 10.0??

0 Kudos