How to show full attribute table with blank popups?

138
1
12-03-2020 06:20 PM
NaomiBegg
New Contributor III

I'm in Portal 10.8.1 and I'm having trouble customising my popups and attribute tables.  I am trying to keep my webmap pop-ups clean with a lot of layers not needing anything more than a title for the majority of users.  However some users will want to go into the attribute table and be able to see more attribute details.

 

I'm having problems controlling the attribute information between these two areas.  If I select 'No Attribute Information' (which is desirable for my popups), it will not allow me to choose attributes to display within the Configure Attributes for the attribute table.  It appears to allow you to do so, but on closing of the configure attributes it automatically de-selects the chosen fields.  The attribute table then shows only the Object ID for the layer rather than the fields of interest.

I've tried to be sneaky and enter a space within the 'Custom Attribute Display', however this picks up on my tricks and reverts back to the 'No Attribute Information'.

If I choose 'A Description From One Field' it is happy for me to select attributes to display in the Configure Attributes for the table.  However this means I am needlessly duplicating information from the header into the popup body or showing some other piece of information that is not suitable to show.

 

Is there another work around that I haven't thought of that doesn't require duplication within the popup yet still shows the fields within the table?

 

Reply
0 Kudos
1 Reply
TaupoDistrict_Council
New Contributor III

I am finding the same thing is happening within AGOL.  I have tried to customise the attribute table widget to show fields not shown within the popup however they are not available.

Reply
0 Kudos