Select to view content in your preferred language

Have popups on by default?

1922
9
Jump to solution
01-28-2022 07:27 AM
ZachBodenner
MVP Regular Contributor

Hello,

When I add services to a web map in ArcGIS Enterprise Portal (10.8.1) the default behavior is that popups are are set to "off." Sometimes I add large grouped layers and it would be nice if I didn't have to go through 70+ layers and set each popup to enabled. Is there a way to default the popups to enabled?

0 Kudos
1 Solution

Accepted Solutions
ZachBodenner
MVP Regular Contributor

Oh wow so I found a great thread that solves this problem beautifully. David_Brooks, your suggestion to use AGOL Assistant tipped me off, but I followed this guide: https://community.esri.com/t5/education-blog/stop-configuring-pop-ups/ba-p/900707 and although you still need to configure your popups once, it worked like a charm!

View solution in original post

0 Kudos
9 Replies
jcarlson
MVP Esteemed Contributor

The defaults come from the layer themselves, I believe. If you look at a service's JSON definition, you can see the popup settings there. If you have access to the services you're adding, you can adjust their default popup settings at the source, and it will carry through to any web map you add them to.

- Josh Carlson
Kendall County GIS
0 Kudos
ZachBodenner
MVP Regular Contributor

I don't know much about adjusting a json at the source (though I do have access to the services), is this is something I can change in the publishing program (Pro in this case)?

0 Kudos
jcarlson
MVP Esteemed Contributor

If you're the one publishing them out of pro, you simply need to configure/enable the popups in Pro prior to publishing them.

Once they're published, you can still change the default settings on each layer's Visualization tab on your portal.

- Josh Carlson
Kendall County GIS
0 Kudos
ZachBodenner
MVP Regular Contributor

Ah see there is one of the issues, these are REST server endpoints as opposed to hosted layers. Interestingly, the popups are enabled in Pro and yet aren't enabled by default when adding the service to the web map.

0 Kudos
David_Brooks
MVP Regular Contributor

@ZachBodenner coincidentally, I have the same issue with a map service with 400 layers in it. When enabled in Pro, they're still disabled in Portal by default. The only way to edit these is through the admin console on the rest endpoint, or by using AGOL Assistant on the Web Map, or editing the Javascript for the web map.

The challenge with my client, is that all of these are "access denied". But we soldier on!


David
..Maps with no limits..
0 Kudos
ZachBodenner
MVP Regular Contributor

Oh wow so I found a great thread that solves this problem beautifully. David_Brooks, your suggestion to use AGOL Assistant tipped me off, but I followed this guide: https://community.esri.com/t5/education-blog/stop-configuring-pop-ups/ba-p/900707 and although you still need to configure your popups once, it worked like a charm!

0 Kudos
ThomasTolko
New Contributor II

I found another solution before trying the AGOL Assistant workaround.

Like others I have hundreds of layers in a single service, and the service was published from Pro with popups enabled - but when I added the service into my webmap from the rest end point URL "add layer from web" the popups were all disabled on all layers.

Adding the whole service again by doing a "Search for Layers" and selecting it from the list and adding it to the map with that method and all the popups were enabled.

Hope that helps someone else.

Pro 2.96, Enterprise 10.9.1, Map Viewer Classic

0 Kudos
AdrianMarsden
Regular Contributor II

OK - we are a Portal site.  I have two Map Image Layers.  Both generated from Pro from the same PC, so with the same version of Pro.  One, when added to a Web Map has popups enabled the other doesn't.

Very confusing!

0 Kudos
AdrianMarsden
Regular Contributor II

Edit - it would appear that presence of stand alone tables in my Pro project was the cause - these didn't need to be in the published service and seemed to have been a source of the issue

0 Kudos