(FIXED) Fail - Upgrade 10.6 to 10.6.1 Fail

1467
2
08-17-2018 02:00 AM
Luiz_AmadeuCoutinho
Occasional Contributor III

I never did a clean upgrade it´s frustrating. I´m trying to upgrade now our server from 10.6 to 10.6.1.

First

- We have a server with Linux and ArcGIS Server + WebAdaptor.

After install the option Click Continue Server Upgrade didn´t work via browser. We tried silent mode and after 3 hours "running" ...nothing .


Second option. We follow some tips from here (forum). The https was disabled and WebAdaptor was removed. It works. The Server was upgraded to 10.6.1 and all content were migrated, but We couldnt enable https again and all SSL Certificates disappeared.


I don´t understand why is so hard to upgrade ArcGIS Server or Portal. I don´t know if works better on Windows Server, but here is not a option for us.


We have another Server with Portal/Datastore/Server/WebAdaptor and I´m thinking if really is a good idea try to upgrade this one. :(

The last time I did an upgrade here was a really pain and We had to create a new Server and Install everything from zero and recover the content manually.

0 Kudos
2 Replies
ThomasEdghill
Community Moderator

Hi Luiz Amadeu Coutinho‌, your experience is certainly not the norm, nor expected. Please reach out to Esri Technical Support for assistance so that this can be investigated further.

Luiz_AmadeuCoutinho
Occasional Contributor III

Thank you Thomas Edghill

We found a solution.

 I´ll share here if someone get the same problem. All SSL Certificates on Certificate Folder was corrupted after upgrade to 10.6.1 . After some tests and lots of Snapshots We follow the steps bellow (on Linux):

  1. Backup your Content before or create a Snapshop
  2. Backup of SSL Certificates folder
  3. Change HTTPS to HTTP on Server Admin
  4. Uninstall Web Adaptor 10.6
  5. Run Server 10.6.1 update
  6. Run Continue Server Upgrade on browser
  7. Stop ArcGIS Server and Overwrite your SSL Certificate Folder with the Folder backup
  8. Start your ArcGIS Server again
  9. Change HTTP to HTTPS on Server Admin
  10. Install Web Adaptor 10.6.1
  11. Configure Web Adaptor 10.6.1
  12. Check if your data and users was migrated correctly.

 And that´s it.                                 

                    ArcGIS Server 10.6.1 Diagnostic Tool

                       Hostname: arcgis...xxxx.xxx.pt
========================================================================

 DIAG000: Check for installation as root                       [PASSED]
 DIAG001: Check for 64-bit architecture                        [PASSED]
 DIAG002: Check OS version                                     [PASSED]
 DIAG003: Check hostname for invalid characters                [PASSED]
 DIAG024: Check /etc/hosts for hostname entry                  [PASSED]
 DIAG004: Check installed packages                             [PASSED]
 DIAG005: Check system limits                                  [PASSED]
 DIAG008: Check HTTP port                                      [PASSED]
 DIAG009: Check HTTPS port                                     [PASSED]
 DIAG010: Check Xvfb ports                                     [PASSED]
 DIAG020: Check hostname IP address mismatches                 [PASSED]
 DIAG026: Check processes for ArcGIS core services             [PASSED]

------------------------------------------------------------------------
There were 0 failure(s) and 0 warning(s) found:

0 Kudos