Error executing tool.: ERROR 000816: The tool is not valid.

5247
2
03-25-2015 01:00 AM
Musa_SerkanArslan
New Contributor III

Hi,

I have posted a GP service. It is created on model builder and published from ArcMap. It includes CreateNearTable tool with some expression.

My ArcGIS server version is 10.2

My Desktop version is 10.2.1

I have posted GP service successfully. But when i run service i was getting this error. "Error executing tool.: ERROR 000816: The tool is not valid."

Than i republished the service (from same mxd and same model) from other Arcmap (version 10.1). Now it works without any problem.

Now i want to know what is the problem with version 10.2.1. Is there a bug. I don't want to use 10.1 anymore. What shall i do?

Any idea?

Thanks...

0 Kudos
2 Replies
ShaunWeston1
New Contributor III

It might be because of the version of server you've got, so the gp tool is built with 10.2.1, but ArcGIS Server is 10.2, so may not be working because of that. Is ArcGIS Server setup on a server? Can you RDP onto the server and run it from there if there is ArcMap on there?

0 Kudos
Musa_SerkanArslan
New Contributor III

Yes, it looks like a version problem. I don't have an Arcmap in server. Currently i am publishing GP services from same or older version Arcmap.

0 Kudos