Distributed Collaboration between AGOL and Portal?

402
5
08-23-2019 08:18 AM
AmyRoust
Occasional Contributor III

Has anyone out there set up a distributed collaboration between their ArcGIS Online and ArcGIS Portal? I got ours set up, but the Portal side (guest) is not receiving anything that is shared by Online side (host). (Yes, I have Access configured as Send and Receive.) I wonder if that is a limitation of our Portal's software version, as we are on 10.6.1?

0 Kudos
5 Replies
HilaryCurtis
Esri Contributor

Hi Amy, I'm from Esri so I'll let others comment on their implementations 🙂 but your version shouldn't be an issue, as collaboration was supported with ArcGIS Online back to 10.5.1. 

In ArcGIS Online, under the collaboration tab > your collaboration > view guests, what is the status of the Enterprise guest? What kind of items have you shared to the Online group (can you double check to confirm that it is the same group you have linked to your collaboration)?

Hilary

0 Kudos
AmyRoust
Occasional Contributor III

Hi Hilary,

Status is set to Active. I double checked the folders and everything looks good. I decided to keep things simple to start and just shared one Map Image Layer in each portal. Both layers are set to be shared with Everyone. Maybe this is a tech support issue?

0 Kudos
HilaryCurtis
Esri Contributor

Hi Amy, sounds good - if you're still seeing it a few days later, I'd go ahead and submit a tech support case. That way the analyst can dig in further and have a closer look at your setup. Quick question, however - do your Enterprise portal logs have any messages around collaboration/publishing/sharing?

0 Kudos
MikeSchoelen
Esri Contributor

The FAQs regarding collaboration have several points that you may need to consider, like the one below. I agree that checking the logs might offer additional insights.

I am not receiving any content from the sending organization via collaboration. What could be the cause of this?

There are a few cases that could be contributing to content not being received in your group. They are as follows:

  • Your group may not have been joined to a collaboration workspace. Contact your system administrator to check that the collaboration workspace has been correctly configured and that the group in question has been joined to the workspace.
  • The scheduled sync may not have occurred yet. When configured by the system administrator, the collaborated content synchronizes on a scheduled interval. The default interval is 24 hours. The system administrator in the sending organization can force a sync using the collaboration REST API. See the collaboration REST API for more details.
  • The available disk space within receiving organizations may have reached 10 GB or less. When such a threshold is reached, no content is synchronized. A SEVERE level log message is recorded to indicate this. The collaboration administrator will also receive notification indicating the content store disk space usage threshold has been reached. Once the disk space is freed up, content synchronizes again. By default, the content store disk space threshold is 10 GB. This value can be modified through the Portal Administrator Directory.
0 Kudos
AmyRoust
Occasional Contributor III

Thank you for posting that -- I had not seen that there was an FAQ. I did create a collaboration workspace and it has existed for several days, so we should have had several syncs since I set it up. There isn't anything severe in my logs that refers to disk space, so no luck there, either. I put in a tech support ticket, so we'll see what happens!

0 Kudos