Date appears in the wrong format in ArcMap

1444
4
Jump to solution
05-28-2017 01:38 AM
AlaaFlaifel
Occasional Contributor

"Date appears in the wrong format in ArcMap"

Despite the fact that Date cells appear in the right format in Excel, the date fails to appear as appropriate when displaying the table in ArcMap.


What might be the issue here?

Thanks,

Alaa

1 Solution

Accepted Solutions
JayantaPoddar
MVP Esteemed Contributor

What happens if you change the value in Excel Sheet from 1/1/2010 to 01/01/2010?

All Single-Digit Date and Month to Double Digit.

And if possible, keep the field_type as TEXT.



Think Location

View solution in original post

4 Replies
JayantaPoddar
MVP Esteemed Contributor

What happens if you change the value in Excel Sheet from 1/1/2010 to 01/01/2010?

All Single-Digit Date and Month to Double Digit.

And if possible, keep the field_type as TEXT.



Think Location
AlaaFlaifel
Occasional Contributor

Thanks Jayanta

This worked well with me.

Best,

Alaa

JoshuaBixby
MVP Esteemed Contributor

From How to use dates and times in Excel:

Excel stores all dates as integers and all times as decimal fractions. With this system, Excel can add, subtract, or compare dates and times just like any other numbers, and all dates are manipulated by using this system.

In this system, the serial number 1 represents 1/1/1900 12:00:00 a.m. Times are stored as decimal numbers between .0 and .99999, where .0 is 00:00:00 and .99999 is 23:59:59. The date integers and time decimal fractions can be combined to create numbers that have a decimal and an integer portion. For example, the number 32331.06 represents the date and time 7/7/1988 1:26:24 a.m.

Some dates are being interpreted as their serial date numbers instead of their Gregorian dates.  Instead of recalculating fields, I wonder if the issue would be solved by highlighting the entire column in Excel and explicitly setting the format to date.

AlaaFlaifel
Occasional Contributor

Thanks for the clarification Joshua.

I tried to set the entire column format as date, but it didn't work however changing the single digit dates to double solved the issue.

Best,

Alaa