Could not analyze datasets DatabaseName.DataOwner.FeatureClass

1325
6
07-26-2018 05:33 PM
BillFox
MVP Frequent Contributor

ArcMap 10.6.1 and Pro 2.2.0

Error "Could not analyze datasets DatabaseName.DataOwner.FeatureClass.
(You might not have sufficient permissions.)"
This occurs only on datasets that are using Esri Binary spatial type.
However, if the statistics are checked in the database they have been updated.

Seems to be a "false error"

Work around, use Geometry spatial type or use a different client to run Analyze Datasets tool.

Runs fine using ArcMap 10.5.0

BUG-000111714‌

Tags (1)
6 Replies
PhilLarkin1
Regular Contributor

Hi Bill

I'm experiencing the same issue with 10.6.1. Were you able to find/register a bug report for this? The number you reference isn't returning a report. 

0 Kudos
BillFox
MVP Frequent Contributor

Hi Phil,

That's the bug # and dialog esri support assigned to our support call.

You probably have to call in and ask to be added to that bug #

0 Kudos
PhilLarkin1
Regular Contributor

Thanks for your reply. 

For reference: this error occurs when running Analyze Datasets on 10.6.1 when analyzing data with the esri spatial binary type on MSSQL 2008 R2 (10.50) or SQL Server 2014 SP2 (12.0.5553.0).

0 Kudos
BrianFausel
Occasional Contributor III

Thanks for the info in this thread. I have experienced the same bug in this environment:

  • ArcMap 10.7
  • MS SQL Server 2017
  • Only happened on feature services with Esri binary spatial type, ones that have been converted to SQL Geometry type did not report the error
0 Kudos
PatrickMcKinney1
Occasional Contributor III

I believe I may be experiencing a similar issue.  When our geodatabase and client (ArcMap) were at 10.5.1 (and windows server 2008R2), I could run the Analyze Datasets tool just fine.  But after we migrated to a new server (windows server 2019), and upgraded geodatabase and ArcMap to 10.7.1, I keep getting this error.

I can still run the Rebuild Indexes tool.  How do you figure out what kind of geometry type the database is using?

0 Kudos
GelcysWilliams
New Contributor III

We are getting this issue as well.  We aren't sure the last time we were able to analyze this 10.5 SDE database successfully - where can you look?  I can check in Include System Tables, and I can Select All datasets to analyze, but when I include Analyze Base or Delta we get the error on SOME layers in the database.  

We were doing this because we are getting an error replicating that we can't resolve - null values in a field that we can't find null values in.  We have posted and reconciled, and deleted all versions under the default, compressed, and can't analyze or replicate successfully.

0 Kudos