Could not add the specified data object to the map. Could not connect ... Map Server

9534
4
01-08-2014 01:56 PM
by Anonymous User
Not applicable
Original User: ecarson

I've just installed and instance of 10.2.

I've published a very basic service. This service appears in ArcCatalog on the desktop and server.

When I try to add the map service to ArcMap on either the following error is displayed.

"Could not add the specified data object to the map. Could not connect to the Map Server"

On the Server I can see the Feature Service as well; this can be added to ArcMap. However I cannot see the feature service on my desktop.

Also on my desktop if I go to the rest services location I can view it in ArcGIS Online.

Any help or suggestions are greatly appreciated.

Regards,
Elliott
0 Kudos
4 Replies
ElliottCarson
New Contributor III
Turns out the instance was only lincensed to basic, it has now been upgraded to advanced and the ArcGIS service restarted.

All services can now be viewed.

Regards,
Elliott
AlisonGaiser1
Occasional Contributor

Elliott,

We are experiencing a similar problem. Did you find any error messages or anything else to help you isolate this problem?

Thanks,

   Alison

0 Kudos
ElliottCarson
New Contributor III


Hi Alison,

This happened some time ago, apart from what's attached to in the orginal message I can't offer anymore insight.

However upgrading from a basic license to the advanced made all the difference.

Regards,

Elliott

AlisonGaiser1
Occasional Contributor

Thanks for the response Elliott.

It turns out that even though we had the same error message ours is a bug. We have ArcGIS Desktop clients at 10.1 and have published a 10.2.2 map service containing a mosaic dataset . When the user tries to load the 10.2.2 map service into ArcMap 10.1, they get the error "Could not add the specified data object to the map. Could not connect to the Map Server". There are multiple NIMs against this issue. (NIM099704, NIM103114, NIM104580).

Thanks!

0 Kudos