Cannot See My Feature Service In REST Services

531
1
09-08-2020 10:02 AM
Mark_Hotz
Occasional Contributor II

I have not needed to use REST Services to acquire a direct path to a specific service Portal in a while, but there is (apparently) a bug in ArcGIS Enterprise 10.6.1 that prevents a user from seeing their feature layer when trying to print from a web app in Portal. 

I realize that there is a bug in version 10.6.1 (I'm in the process of upgrading, but that process is currently temporarily on-hold), but there is a workaround using a method I have used in the past with map images using REST Services.

However, I'm currently unable to see any feature services in REST Services (only Map Images).  These feature services show up in ArcGIS Server Manager (services that the user can edit), but I need to get the path to the specific layer in REST Services to (apparently) bypass the bug that is preventing the user from seeing the layer when attempting to print.

Is there an ArcGIS Enterprise rule of which I'm currently unaware that doesn't allow feature services to show up in REST Services (i.e. only layers published as Map Images)?.

Thank you

0 Kudos
1 Reply
CalvinLietz
Esri Contributor

Hi Mark,

When viewing services from Server Manager, you will not see any feature services listed (except for in the Hosted folder if your ArcGIS Server site is set as the designated hosting server). This is because the services are map services first - with the option of enabling feature access on top of the map service.

You can easily identify the capabilities of the map service by clicking on the name of the service in Server Manager and viewing the Capabilities tab:

When you highlight the Feature Access checkbox, you can see the REST URL listed below. Clicking this link will redirect you to the REST endpoint of the feature service, which can be added to any web map or application of your choosing.

A full list of capabilities for map services can be found here: Set map service properties—ArcMap | Documentation 

I hope this helps!

Best,

Calvin