ArcGIS Pro Compatibility with SDE Versions

731
3
Jump to solution
02-22-2018 10:47 AM
MichaelVolz
Esteemed Contributor

Looking to the future I am wondering what ArcGIS Pro compatibility there will be with SDE versions.  Currently ArcGIS Pro is up to v2.1.1 and SDE which is bundled with ArcGIS Enterprise (ArcGIS Server) is at 10.6 so it's a different numbering system.

For the current environment, does this mean that ArcGIS Pro is compatible with all SDE versions from 10.1.x and newer (It seems like this would be the case as I have used Pro in limited testing against both 10.3.1 and 10.5.1)?

In the future, will there be a time when a version of ArcGIS Pro (e.g. 2.2 or higher) will only be compatible with a newer version of SDE (e.g. 10.6)?

0 Kudos
1 Solution

Accepted Solutions
George_Thompson
Esri Frequent Contributor

I think that you may be looking for this document: Client and geodatabase compatibility—Geodatabases | ArcGIS Desktop 

--- George T.

View solution in original post

3 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Supported database management systems 

http://pro.arcgis.com/en/pro-app/help/data/databases/dbms-support.htm

There are other links on that page for specifics to your situation

George_Thompson
Esri Frequent Contributor

I think that you may be looking for this document: Client and geodatabase compatibility—Geodatabases | ArcGIS Desktop 

--- George T.

View solution in original post

MichaelVolz
Esteemed Contributor

Thanks to both Dan and George as George has the information that answers the question for the present.  I would love to know what ESRI's plans are for future compatibility as I will need to have both ArcMap (main current desktop app) and ArcPro in use together for at least 2 more years and I'm concerned about having to make a desktop and SDE upgrade only because ArcGIS Pro was no longer compatible with the SDE version that was in production.

0 Kudos