Select to view content in your preferred language

ArcGIS Portal Map Viewer Get Coordinates

1212
9
Jump to solution
06-12-2023 03:40 AM
OliverIshmael
Occasional Contributor

For most of our users a tool is displayed beside the cursor coordinates in the bottom left corner of the map viewer, which allows them to "click to enable clicking map to get coordinates" as seen in this screenshot, highlighted in red:

OliverIshmael_0-1686566198215.png

However, for other users with the same role this does not display:

OliverIshmael_1-1686566295782.png

Does anyone know why this is / how this is turned on/off?

0 Kudos
1 Solution

Accepted Solutions
ChrisUnderwood
Esri Contributor

Hello @OliverIshmael  , yes we can see the problem now too. But it only occurs when the browser window is quite small, or the browser (not the map itself) is Zoomed it. Does your particular user have a smaller screen or use the browser Zoom function ? If you want this recorded as a Bug, please contact your local distributor so that we can formalise the process.

View solution in original post

9 Replies
ChrisUnderwood
Esri Contributor

Hello @OliverIshmael  , according to the Help pages, the Web AppBuilder Coordinate Widget displays coordinates in the WGS_1984_Web_Mercator_Auxiliary_Sphere (WKID 3857) projection. Is it possible that somehow one of your users is using a different coordinate system to the others, eg perhaps by using a different Basemap or similar ?

https://doc.arcgis.com/en/web-appbuilder/latest/create-apps/widget-coordinates.htm

0 Kudos
OliverIshmael
Occasional Contributor

Thanks for advice Chris, however, having tested web apps with both British National Grid and WGS84 data I can confirm that the coordinate widget tool works with data in both projections and even in apps where data has erroneously been added in both projections simultaneously. 

The issue we are seeing is user-specific, in that we have produced an app for all members of staff that they are unable to edit. Some of them see the coordinate widget while others do not and we are still unable to determine why this is.

0 Kudos
ChrisUnderwood
Esri Contributor

Hello @OliverIshmael , do you see the same user-specific problem with a simple App created using ArcGIS Online rather than ArcGIS Enterprise ? If so, are you able to Share that App publically so that we can try it ourselves ?

0 Kudos
OliverIshmael
Occasional Contributor

Hello @ChrisUnderwood apologies for the delay, the user has now tried to use the app in ArcGIS Online and is also unable to see the coordinate widget here too.

I tried to search for ChrisUnderwood but i couldn't find you, so what username should i search for to add you to the group?

0 Kudos
ChrisUnderwood
Esri Contributor

Hello @OliverIshmael  please make sure your App does not contain any confidential information, then set the Share Level to Public, and post the URL here.

0 Kudos
ChrisUnderwood
Esri Contributor

Hello @OliverIshmael  , yes we can see the problem now too. But it only occurs when the browser window is quite small, or the browser (not the map itself) is Zoomed it. Does your particular user have a smaller screen or use the browser Zoom function ? If you want this recorded as a Bug, please contact your local distributor so that we can formalise the process.

OliverIshmael
Occasional Contributor

@ChrisUnderwood thanks for getting back to me. Yes, I can see now that the widget disappears from the Edge browser when it's zoomed in >150%. The user in question is on annual leave for 2 weeks now so there'll be a delay before i can get this tested with them, but this is likely to be the solution and the ExB workaround is appreciated.

0 Kudos
ChrisUnderwood
Esri Contributor

@OliverIshmael  I've also checked with the ArcGIS Online Experience Builder (as opposed to Web AppBuilder) and the problem does not occur with the Coordinate widget there, if that offers a way forward for you.

0 Kudos