AGS service never remembers password

114
4
08-15-2019 01:28 PM
New Contributor III

Does anyone else have this issue?

When I restart my ArcGIS Server service in Windows, it always fails because the password that is cached isn't correct. I retype the password every time manually. This is blocking for Task Scheduler tasks to automate this. The windows user that owns the service is the AGS user per the install guide.

Reply
0 Kudos
4 Replies
Esri Contributor

Hello Travis,

Just to confirm, are you using:

1. Local account

2. Domain Account

3. gMSA account (domain account) or

4. Local System Account

More info found on the docs below:

The ArcGIS Server account—ArcGIS Server Administration (Windows) | ArcGIS Enterprise 

Reply
0 Kudos
New Contributor III

Just a local account. Before we would have to restart it manually every time there was a VM reset (over weekends, planned maintenance, etc). It would say the account PW was incorrect and we'd change it. Now we created a simple .bat file to hopefully automate this:

net stop ArcGIS Server
net start ArcGIS Server

and made a task scheduler item to run this.

It has the 0x2 error right now and am looking up the causes.

Reply
0 Kudos
Esri Contributor

I would see about running the Configure Arcgis Server Account Utility to see if this remedies the issue.  The ArcGIS Server account—ArcGIS Server Administration (Windows) | ArcGIS Enterprise  If you have already done this, and the issue persist, I would question to see if there is any local GPO (group policy) that is somehow effecting this. Probably check with your IT team on that.

Another possible route, would be creating another local admin account? and set that as the services account and see if that works?  

New Contributor III

Thx will try these.

Reply
0 Kudos