AGE Builder 10.7.1 - The Web Adaptor URL cannot be reached

10-17-2019 01:33 AM
Occasional Contributor III

Trying to install AGE 10.7.1 with Builder.

Before launching the setup, i changed my etc/hosts file to let my server see itself as rather than its FQDN ( suggested in 

The etc/hosts now has this line


To confirm it works, pinging the server with ping -a  MY_SERVER_IP shows rather than the FQDN.

I launched the installation and everything went fine (all green check marks).

Then, opening the configuration wizard in the browser, (i changed the URL from http://localhost:6080/arcgis/enterprise to ), after filling all the information, I reach the error:

The wizard is redirecting to the FQDN (, and there's no way I can make it work.

I can however reach which redirects me to the Web Adaptor configuration page ( ), meaning that probably the etc(hosts trick worked.

Unfortunately, I have no idea how I would make the Builder configuration wizard to point to this address rather than the FQDN one.

I am again stuck with installing AGE with Builder and I REALLY hope someone will shed a light on how I can solve this without removing everything and reinstalling each component manually (that is one day of work at least).

There's also this other thread where Jonathan Quinn‌ says:

1) Use the hosts file under C:\Windows\System32\drivers\etc to set the alias so the Builder will use that hostname for configuring everything:



This however seems to have failed in my case, and according to the many threads I found on Geonet, most people just gave up and did a manual install of the AGE components separately...

0 Kudos
4 Replies
Occasional Contributor III

In addition, i found an interesting folder (C:\ProgramData\ArcGISBuilder10.7.1)with the AGE Builder logs, with the Web Adaptor logs for both server and portal (ServerWa.log and PortalWa.log).

They both have this inside:

   Property(S): ComputerName = SVKSI058ANEW

no trace of whatsoever.

Is it possible that the etc/hosts trick is not working? Has anybody else out there tried it, or am I the only one in need of a simple installation which ends up having a single machine deploy of AGE that can be reached via a public domain rather than a (in most cases) useless FQDN?


0 Kudos
Esri Notable Contributor

It seems like it didn't work, but I've never experienced that on my end. Does your machine have multiple NICs?

All of that aside, best practice is to have the components, (Portal, Server, and Data Store) on an internal network network that is isolated via a firewall. Within your DMZ you'll have a web adaptor or reverse proxy to send requests to the backend servers. Putting everything on one machine that is accessible by the internet is definitely not typical for a production or public facing system.

0 Kudos
Occasional Contributor III

First of all, thanks for your feedback on this.

It seems like it didn't work, but I've never experienced that on my end. Does your machine have multiple NICs?

I am not sure about it, I need to check.

Anyway, I absolutely don't wanna sound polemical, so keep my following words as my thoughts and as a constructive criticism.

All of the things you justly pointed out are completely right and useful, and I appreciate your answer, but i really think they should be clearly stated somewhere as a prerequisite or an Important note/Warning in the official docs (Welcome to the ArcGIS Enterprise Builder installation guide—ArcGIS Enterprise Builder Installation G... ).

Many other people (myself included) might otherwise be thinking that Builder is an easy sort of one-click installer that is supposed to do all the magic of the installation process, network aspects included. This does not clearly see the case, especially when you come up with a configuration that once is up, is super hard (if not impossible) to adjust.

Also, as the Web Adaptor is one of the components included in the Builder installation, i don't understand the need to have another

web adaptor or reverse proxy to send requests to the backend servers.

New Contributor II

I have the same issue, did you find a solution that you still remember? 🙂

0 Kudos