10.4.1 Server + Portal clone

356
3
07-02-2018 01:17 AM
DanielSotreanu
New Contributor III

Hi All,

Does anyone tried (successfully) to clone a virtual machine hosting both a Server and Portal (v10.4.1)?

I would like to know what changes needs to be done on the clone to make it work independently.

Thanks!

0 Kudos
3 Replies
JonathanQuinn
Esri Frequent Contributor

Unfortunately, there are no out of the box tools for cloning an ArcGIS Enterprise deployment. There are python scripts you can use:

clone_portal_users_groups_and_content | ArcGIS for Developers 

These would get you most of the way, but services are not cloned so you have to republish those. You'll also need to then update any references in your webmaps to point to the correct services URLs, which can probably be done when you're copying the items.

What is your use case for cloning? Are you attempting to create a staging environment?

0 Kudos
DanielSotreanu
New Contributor III

Thanks Jonathan, I want to save some time by just cloning a clean install versus installing all the components 5 times.

Indeed the services are the only one left behind. I was able to make all the other cloned pieces to work, but the old services address is being invoked.

The reference does not include service migration..only users, groups, contents.

0 Kudos
JonathanQuinn
Esri Frequent Contributor

Are you referring to the reference in webmaps? While you're looping through the content, if it's a webmap item, you should loop through the operational and basemap layers and update the URLs.

0 Kudos