10.3 services won't print

1030
9
09-13-2016 10:26 AM
RobertKirkwood
Occasional Contributor III

The print services published on 10-3 will not print map-services also published on 10-3.  We have tried several combinations of print-service + map-service location:

 

as:

PrintService  --> MapService -->  RESULT

 

10-3   -->  10-3  --> FAIL

10-2  -->  10-3  --> FAIL

10-3  -->   10-2  --> SUCCESS

10-2  -->  10-2  -->  SUCCESS

Has anyone seen this error?

0 Kudos
9 Replies
JonathanQuinn
Esri Frequent Contributor

Can you describe the problem and your setup a bit more?  What error are you actually seeing?  Are the services secured?  Are you using IWA?

RobertKirkwood
Occasional Contributor III

I am just getting an "Error: Unable to complete operation." None of the services are secured. They work on the 10.2 and the 10.3 print service prints 10.2 services.

0 Kudos
RobertKirkwood
Occasional Contributor III

Log Print Error

0 Kudos
JonathanQuinn
Esri Frequent Contributor

Can you try to print the services over http?  The certificate seems fine, but I'd be interested in seeing if http works.  Can you 10.3 Server make outbound connections to https://wygiscservices10-3.wygisc.org/arcgis/rest/services?  If you were to sign onto the 10.3 Server machine with the account running the ArcGIS Server service, can you reach that URL successfully?

RobertKirkwood
Occasional Contributor III

I am not sure how to do this? 

0 Kudos
JonathanQuinn
Esri Frequent Contributor

If you sign onto the Server machine with your normal Windows account, take a look at the Services window, (Administrative Tools > Services), or the details tab in the Task Manager.  If you use Services, take a look at the Server service and see what user is running it:

If you use the Task Manager, see what user is running each Server process:

Then sign in with that user name to see what types of outbound requests that user can make.

RobertKirkwood
Occasional Contributor III

We cannot get to that URL from the machine. 

0 Kudos
JonathanQuinn
Esri Frequent Contributor

Ahh, then that's the problem.  When you print, ArcGIS Server makes outbound requests to each URL you're trying to print.  If that machine can't reach that URL due to firewall settings or something else, then you won't be able to print the services coming from that URL.  You should reach out to your IT staff to sort that out.

RobertKirkwood
Occasional Contributor III

Thank you!

0 Kudos