WebApp Builder for Portal

1254
1
Jump to solution
07-28-2016 02:01 PM
AndyBohnhoff
New Contributor II

When I go to build an app using the WebApp Builder (Share - Create a WebApp - Select App) it shows the app in a new tab but does not allow me to configure the app. I am in my company's Portal while accessing the App Builder and am using hosted data from SDE. When opening the new App, all the data displays just fine but like I said - it does not give me the option to configure the app.

Conversely, when I do this same process using my personal ESRI credentials, I get the options to fully configure each app. Could this be something that needs to be configured in my Portal Organizational account or does the WebApp Builder within Portal act differently than the WebApp Builder within ArcGIS Online? Thanks!

The picture attached is my current view when accessing the app.

Derek Law

0 Kudos
1 Solution

Accepted Solutions
DerekLaw
Community Moderator

Hi Andy,

The screenshot you provided shows the Basic Viewer template and not Web AppBuilder. When you are in the Portal map viewer, you save your web map > Share > Create a Web App

ShareDialog.jpg

By default the Configurable Apps tab appears (which shows the application templates). If you select a template, you would create the new item and should be able to configure it. In your case, you should select the Web AppBuilder tab,

CreateNewWebAppDialog.jpg

You complete the metadata and click Get Started. This should open up Web AppBuilder within Portal for ArcGIS in your web browser. Web AppBuilder does not need to be "configured" in Portal, it is already included and enabled by default.

FYI, Web AppBuilder for ArcGIS was added into Portal for ArcGIS at the 10.3 release and later.

Hope this helps,

View solution in original post

1 Reply
DerekLaw
Community Moderator

Hi Andy,

The screenshot you provided shows the Basic Viewer template and not Web AppBuilder. When you are in the Portal map viewer, you save your web map > Share > Create a Web App

ShareDialog.jpg

By default the Configurable Apps tab appears (which shows the application templates). If you select a template, you would create the new item and should be able to configure it. In your case, you should select the Web AppBuilder tab,

CreateNewWebAppDialog.jpg

You complete the metadata and click Get Started. This should open up Web AppBuilder within Portal for ArcGIS in your web browser. Web AppBuilder does not need to be "configured" in Portal, it is already included and enabled by default.

FYI, Web AppBuilder for ArcGIS was added into Portal for ArcGIS at the 10.3 release and later.

Hope this helps,

View solution in original post