Portal upgrade issue

1328
14
11-28-2019 07:28 AM
Haider_Ali
Occasional Contributor

Hi,

I am facing an issue while upgrading ArcGIS Portal from 10.6.1 to 10.7.1. The problem is occurring when I ran the upgrade portal (trough tool available in installation directory and web interface of portal) with below error messages

  1. esri.arcgis.portal.admin.core.site.migration.MigrationException: Failed to upgrade the PostgreSQL from 9.6.8 to 10.6.
  2. esri.arcgis.portal.admin.core.site.migration.MigrationException: java.lang.Exception: Source path C:\arcgisportal\db\postmaster.pid does not exist.

Note that I already checked the permission of arcgisportal folder and the account through which portal service is running has write access on it.

Tags (2)
14 Replies
ChristianStern
New Contributor III

Did you ever manage to solve this problem? It seems that I am running into the same issue while upgrading from 10.6.1 to 10.8. This had happend also when trying to upgrade from 10.6.1 to 10.7.1 but finally I sticked to 10.6.1 and hoped it would be better with 10.8...

Christian

0 Kudos
Haider_Ali
Occasional Contributor

ESRI support team was able to fix the issue using following steps

-In the arcgisportal/content/items folder, there was a kml folder, removed that folder from folder
-Ran the following workflow:
   1.Stop Portal for ArcGIS service
   2.Rename Content, db, and index folders inside C:/acrgisportal to to Content_old, db_old, index_old
   3. Copy the Content, db and index folders from C:\arcgisportal\upgrade-backup\10.6 and place them into C:\arcgisportal
   4. Clear browser cache and close browse

Run the setup again


-Site was successfully upgraded

ChristianStern
New Contributor III

Ali,

this did the magic also for me! Thank you very much for your help.
I wonder now if something is missing in the portal because we copied the 10.6 content...? What did you do with the "_old"-folders?

Best wishes

Christian

0 Kudos
JonathanQuinn
Esri Frequent Contributor

So the presence of the "kml" folder caused the upgrade to fail? Was this logged as a bug?

Christian Stern‌, you can delete the _old folders when you're confident the upgrade completed successfully.

PhilippeVan_De_Vreken2
New Contributor III

Hi Ali,

I run into the same issue. However, I don't have a 'kml' folder, but I will try your workaround

Just one question about the workflow that fixed it: when you say "run the setup again": do you mean running again the Portal for ArcGIS installer? Or just redoing the Continue Portal Upgrade part in the browser?

Thank you and best regards

Philippe

0 Kudos
Haider_Ali
Occasional Contributor

Hi Philippe,

                     Its better to create a support ticket then if kml folder is not there , run the setup again meant  Continue Portal Upgrade part in the browser

Regards,

Haider

0 Kudos
PhilippeVan_De_Vreken2
New Contributor III

Thank you for your answer. I will log a support ticket indeed

0 Kudos
ChristianStern
New Contributor III

Hi Philippe,

in the end, this workaround didn't help me because it brought the system (content) back to the state of 2018 when I had 10.6 installed. So I also suggest to open a case.

That's what I will also do in the end but not right now because of time reasons.

Good luck

Christian

0 Kudos
PhilippeVan_De_Vreken2
New Contributor III

Thanks for your reply

0 Kudos