Different home page items for each group in the portal

1097
9
Jump to solution
03-08-2017 12:04 AM
AliBarakat
Occasional Contributor II

Hello,

What I am trying to do is to show different items on the home page based on the group member who is signed in.

Example:

Group 1 can see items A B C D E F

Group 2 can see items A B C

Group 3 can see B D F

Group 4 can see A B E

etc..

and sometimes the items can be related, meaning for example item F is the webmap of the item A

how is this possible?

0 Kudos
1 Solution

Accepted Solutions
DerekLaw
Esri Community Moderator

Hi Ali,

As Paul said, the functionality you are asking for: a different looking homepage for different group members, is not supported in Portal for ArcGIS. I suggest you submit this enhancement request on the ArcGIS Ideas site,

ArcGIS Ideas 

Hope this helps,

View solution in original post

9 Replies
PaulDavidson1
Regular Contributor

This is not built into Portal as far as I know.

However, Geo-jobe does make a tool, Mapfolio, that should do what you want.:

http://www.geo-jobe.com/mapfolio/

AliBarakat
Occasional Contributor II

Does anyone else have an idea about this?

0 Kudos
DerekLaw
Esri Community Moderator

Hi Ali,

As Paul said, the functionality you are asking for: a different looking homepage for different group members, is not supported in Portal for ArcGIS. I suggest you submit this enhancement request on the ArcGIS Ideas site,

ArcGIS Ideas 

Hope this helps,

AliBarakat
Occasional Contributor II

Thank you ‌pk_davidson and Derek Law‌ for your replies.

i have also faced the following issue in the portal home page items:

I had a story map tour working fine and shared with the "featured maps and apps" group and it is appearing on the home page item list.

I deleted this item, and now the home page is still showing a blank box that leads to this app (eve though this app doesn't exist any more).

if i search for the app i can still find it as well, i cant open it, i cant view the item details, i cannot do anything to it because it does not exist.

How can i permanently delete it from the home page? it is really annoying to show a blank box.

Thanks again

0 Kudos
PaulDavidson1
Regular Contributor

Ali:

I have not seen that specific issue.

I have seen, and others have reported, ghost services left in Portal after they have been deleted.

In my case, it was in a dev portal so I just rebuilt the Portal.

And it was not on the home page.

The deleted service just kept showing up in my My Content lists.

I have taken to removing any item from any group membership before deleting it.

I don't recall seeing any specific solution for this but you would need to search Geonet to be sure.

If I were you, I would put in a support ticket and have Esri help work through this or create a bug report.

You have refreshed/deleted your browser cache, right?

0 Kudos
AliBarakat
Occasional Contributor II

Hi Paul,

yeah i definitely cleared the cache many times.

Next time for sure we should remove sharing of any item before deleting it.

I hope someone has a solution for this.

0 Kudos
DerekLaw
Esri Community Moderator

Hi Ali,

> ... I deleted this item, and now the home page is still showing a blank box that leads to this app (eve though this app doesn't exist any more). ... if i search for the app i can still find it as well

One suggestion to try and resolve: go to the ArcGIS Portal Directory and rebuild the indexes.

  • Open the ArcGIS Portal Directory and sign in with the initial administrator account. The URL is formatted https://portal.domain.com:7443/arcgis/portaladmin.
  • Click System > Indexer > Reindex.
  • Click the Mode drop-down list, and select Full.
  • Click Reindex.

Hope this helps,

AliBarakat
Occasional Contributor II

Thank you Derek,

I read that Reindex is usual used when we upgrade the portal.

But does it affect anything in the portal??

0 Kudos
DerekLaw
Esri Community Moderator

Hi Ali,

Yes, the reindex helps to ensure that Portal items are all indexed properly and are in sync. Hence my suggestion to try and use it to help resolve your issue. If not, then please contact Esri Tech Support so they can investigate further.

Hope this helps,