Create New User not through HTTPS connection after disable anonymous access in portal

515
4
Jump to solution
03-09-2021 02:48 AM
Labels (1)
Izzat
by
New Contributor III

Version : ArcGIS Enterprise 10.8.1

How to make sure Create an Account page are access through HTTPS only when disable Allow anonymous access to your portal .

This only happen when use same network or access through VPN. If I access the page through outside network, it will redirect to HTTPS protocol.

Anonymous Access Setting

Disable anonymous Access

Enable anonymous Access

Setting > Security

IzzatunnasiriIslamABRahman_0-1615286358035.pngIzzatunnasiriIslamABRahman_1-1615286358038.png

home/signup.html

IzzatunnasiriIslamABRahman_2-1615286358044.png

 

IzzatunnasiriIslamABRahman_3-1615286358048.png
0 Kudos
1 Solution

Accepted Solutions
jcarlson
MVP Notable Contributor

You can also approach this from your Web Adaptor machine, by forcing HTTPS URL redirects in your web server settings. Here's an article discussing how to do it on IIS.

- Josh Carlson
Kendall County GIS

View solution in original post

4 Replies
JayantaPoddar
MVP Esteemed Contributor

Configure HTTP

1. Sign in to the portal website as an administrator of your organization. Click Organization and click the Settings tab.
2. Click Security on the left side of the page.
3. Portal for ArcGIS enforces HTTPS communication by default. To allow both HTTP and HTTPS communication in your organization, uncheck the Allow access to the portal through HTTPS only check box. If you have previously unchecked this box, rechecking it will once again enforce HTTPS only communication for your portal.



Think Location
0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Is the Allow access to the portal through HTTPS only check box, unchecked? You could follow these steps.

1. Sign in to the portal website as an administrator of your organization. Click Organization and click the Settings tab.
2. Click Security on the left side of the page.
3. Portal for ArcGIS enforces HTTPS communication by default. To allow both HTTP and HTTPS communication in your organization, uncheck the Allow access to the portal through HTTPS only check box. If you have previously unchecked this box, rechecking it will once again enforce HTTPS only communication for your portal.



Think Location
0 Kudos
Izzat
by
New Contributor III

Yes.. Allow access to the portal through HTTPS only check box is checked

IzzatunnasiriIslamABRahman_0-1615292548464.png

 

0 Kudos
jcarlson
MVP Notable Contributor

You can also approach this from your Web Adaptor machine, by forcing HTTPS URL redirects in your web server settings. Here's an article discussing how to do it on IIS.

- Josh Carlson
Kendall County GIS