Select to view content in your preferred language

Cannot share non-owned items to groups in Portal

2832
15
11-17-2022 08:36 AM
RyanUthoff
Regular Contributor

I'm currently using ArcGIS Enterprise 10.9.1 and am having an issue that did not previously exist in our 10.6.1 environment.

Using a Portal account with admin permissions, I cannot share items owned by another user to any groups. Both members (myself and the person who owns that item) are in the group I am trying to share the item to. I've verified in the group settings that anyone in the group can contribute content. 

This was not an issue in 10.6.1. I was able to share items, regardless of who they are owned by, to any group, as long as the item owner was also in that group.

Is this expected behavior in 10.9.1? If not, is there anything I need to do differently to be able to share content not owned by myself?

0 Kudos
15 Replies
Scott_Tansley
MVP Regular Contributor

I can't comment on expected behaviour, but as a temporary workaround, could you move the item to your content (reassign ownership), share it to the group, and then reassign it back to the original owner?  I appreciate the UX may not be great, but might help in the short term?

Scott Tansley
https://www.linkedin.com/in/scotttansley/
0 Kudos
RyanUthoff
Regular Contributor

Yeah, that is our workaround for now. It works, but it's not great because it's an extra step in the process that we didn't have to previously do. And, personally I don't think it should be expected behavior because the green message in the top right of the screen pops up and says that it was successfully shared (clearly, it did not successfully share because the item is not in the group).

0 Kudos
Scott_Tansley
MVP Regular Contributor

Have you raised it with Esri (or distributor) support to see if it's a bug?

 

Scott Tansley
https://www.linkedin.com/in/scotttansley/
0 Kudos
RyanUthoff
Regular Contributor

Not yet. I was hoping it was something simple or stupid I'm doing wrong that someone else might know before I reach out to support.

Scott_Tansley
MVP Regular Contributor

if it helps, then I've just tested:

  • sharing from the item page (not owned by me.  I'm full admin) and I get a green popup (top-right) that states success.
  • going organisation -> members -> {user} -> manage items and change sharing.  I got a green success message.

in both cases it fails to share to the group.  I agree the system appears to work in the way that you expect, but fails to actually share.  I do not believe you are doing anything wrong/stupid.  

My portal is fully patched with the exception of the latest Portal 2022 security update 2 patch.

Hopefully that helps?

Scott Tansley
https://www.linkedin.com/in/scotttansley/
RyanUthoff
Regular Contributor

Thank you so much for testing that for me! I'm glad it's not just me. I'll go ahead and document a bug with Esri support.

Scott_Tansley
MVP Regular Contributor

I’ll apply the update 2 patch in about 30 mins and retest. Just in case?

Scott Tansley
https://www.linkedin.com/in/scotttansley/
0 Kudos
RyanUthoff
Regular Contributor

My Portal was patched exactly as yours. I'm also applying update 2 patch right now.

0 Kudos
Scott_Tansley
MVP Regular Contributor

Patch applied, now fully up to date.  No change.  Still get a green success on change, but nothing material happens.

Scott Tansley
https://www.linkedin.com/in/scotttansley/
0 Kudos