Add Features not showing editable layer

445
4
07-19-2021 08:22 PM
Labels (3)
RebekahPolette
New Contributor III

Hi all, 

I work with referenced feature layers (SQL) in an Enterprise/Portal environment. These layers are available in web maps for editing data. 

One of my feature layers has a layer that although editable does not show any templates in the 'Add Feature' panel. All other layers in the same feature set populate with a template. I can edit existing features in this layer but not create new features.

I have tried a fresh overwrite and resetting symbology to no avail. 

Screen grab below, any help appreciated

Tags (2)
0 Kudos
4 Replies
ReeseFacendini
Esri Contributor

Is there a definition query on the troublesome layer?  I have had issues before where I had set a def-query and it messed with my templates and editing.

0 Kudos
RebekahPolette
New Contributor III

Hi @ReeseFacendini 

No def-query, and only simple symbology. 

Regards

0 Kudos
SarahMuir
New Contributor

Hi Rebehah,  I am currently having this same problem. Were you able to get this resolved? If so, can you give me some pointers on how you did that. Thank you!

 

Sarah

0 Kudos
RebekahPolette
New Contributor III

Hi Sarah, 

Yes, I did.

This was the solution from ESRI TechSupport...

Case Resolution

The primary symbology for the layer in question was set to "Unique Values" with a particular field specified that had empty data values across the feature dataset. On adjusting "Field 1" to a different field which was confirmed to have data present for all fields, and re-sharing the layer to Portal for ArcGIS, the feature template for the layer was available to select when adding new features.

 

Regards

Rebekah 

0 Kudos