Selector won't filter map data

695
5
04-02-2019 09:16 AM
Gracer_Mike
New Contributor

I have a selector that allows me to filter data in my charts, but not in my map.  The map is an ArcMap map service.  The Ops Dashboard map, charts, and selector are all using the same layer from the map for their data.  Any idea why it won't let me filter the points in my map? 

Tags (3)
0 Kudos
5 Replies
JustinPence2
Occasional Contributor

I am running 10.7 Enterprise, and I notice the same behavior.  I wish I could filter based on the cached map service, as my feature is made up of 10's of thousands of points, and it is not ideal to host them as a feature service.

The other work around I could find is adding the map service as the rest service URL, and add layer from web.  However, this will draw each feature similar to as a hosted feature service.  Depends on your scale and amount of features to whether or not it will work.

0 Kudos
ChristopherBride1
New Contributor

I have the same problem. Are you saying that it would work as a hosted service?

0 Kudos
JustinPence2
Occasional Contributor

It works as a feature hosted service.  It does not work directly as a tiled map service, which is a shame.  I find many tools/widgets support hosted featured services and not tiled map services.  

0 Kudos
BenjaminBlackshear
New Contributor III

Had this issue as well and was able to resolve it by removing the data from the web map and adding it again as individual layer(s) rather than as the link to the service. So adding https://servername/webadaptorname/rest/services/foldername/servicename/MapServer/0

instead of https://servername/webadaptorname/rest/services/foldername/servicename/MapServer

0 Kudos
JustinPence2
Occasional Contributor

That'll work.  However, it the behavior/response is similar to a feature service, and not a tiled service.  For most, it'll work.  But when you have tens of thousands of features, a tiled map service performs better.  

0 Kudos