always prompted for credentials

800
5
04-19-2018 07:01 AM
FabioD_Ovidio
New Contributor II

Hi,

even if I share an operation dashboard on arcgis on line as public item and If I haven’t subscriber content inside (just a public web Map), I am not able to accees it in anonymous way. AGOL always prompt users for credentials.

Why? Is it a bug?

Thank you

Fabio

0 Kudos
5 Replies
Juan_ManuelAngel_Cuartas
New Contributor II

Can you Share with us the link of the dashboard ?

0 Kudos
AaronPulver
Esri Regular Contributor

Does your organization allow anonymous access? If not, check out this answer.

Are all of the layers in the webmap also shared publicly?

0 Kudos
FabioD_Ovidio
New Contributor II

yes, the all the laers are public. Anyway, if I use arcgis.com instead of my-organization.com it works.

Thanks

0 Kudos
FabioD_Ovidio
New Contributor II

If I have instead a public dashboard with a public web map in which all the services are secured I am always redirected to prompt credentials (on arcgis server) even if I refresh the Identity state (by using esri.id.initialize via Javascript API) before calling the dashboard.

Why? Is there a way to modify this behaviour?

Thank you

Fabio

0 Kudos
DerekLaw
Esri Community Moderator

Hi Fabio,

It might be that your ArcGIS Online organization does not allow anonymous access. You can confirm by checking if the “Allow anonymous access to your organization's website.” setting is disabled in the Security tab under your org’s Setting page.

Hope this helps,

0 Kudos