Updating data source in WebApp Builder wipes out queries, etc.

1670
2
Jump to solution
10-15-2015 09:38 AM
TiffanyTuro
New Contributor III

Hi All,

Is anyone out there using webapp builder to build dashboard summaries of their AGOL data?  The problem I am having is that I often have to create a new version of the same layer so that I can strip off the photos.  This makes the layer perform better in collector with the syncs, etc.  When I am in my webapp and I set the source data to reference the newest layer (it has a new name, like Layer2), it wipes out all my query arguments, charts, searches, etc.  This is such a hassle to have to recreate each of those.  I had hoped the template function would let me save my file structure with all those arguments, but the template is not intended to work that way.  Publishing the service over the original, using the same name, would likely solve my webapp problem, but generates various other data problems for my collector usage.  Is anyone else doing this, and have you found a work around?  The wepapps are a great way to share the results with managers over our internal webpage, and I really like them.  I just don't love having to rebuild it every two weeks.

Thanks for your ideas.

-Tiffany

0 Kudos
1 Solution

Accepted Solutions
deleted-user-xm1nmvw2ZKoH
New Contributor II

Hi Tiffany. I have dealt with this issue before by using the AGO Online Assistant tool to view and update the applications JSON configuration.

In viewing your applications JSON, scroll down towards the bottom and you will see the configuration for all the widgets in your application.  From there you can update all URL's configured in the widget.

View solution in original post

2 Replies
deleted-user-xm1nmvw2ZKoH
New Contributor II

Hi Tiffany. I have dealt with this issue before by using the AGO Online Assistant tool to view and update the applications JSON configuration.

In viewing your applications JSON, scroll down towards the bottom and you will see the configuration for all the widgets in your application.  From there you can update all URL's configured in the widget.

TiffanyTuro
New Contributor III

Thank you so much.  You don't want to know how many tech support calls I've made with no luck on this topic.  It took you three sentences to set me straight.  This forum is such a great resource.  Thank you for the help.

-Tiffany