Failed to download - "Unable to construct a WebMapLayer"

2399
8
Jump to solution
09-29-2014 11:42 AM
MarkPeacey2
New Contributor II

I've setup an AGOL hosted feature service with a NZ basemap (default AGOL supplied option which is a 10.2.2 service and supports offline) and when I go to try take it offline I press download, define the areas and I get the message, "The map failed to download. The map 'title here' failed to download with message: Unable to construct a WebMapLayer". This is with Collector for Android version 10.2.5, build 1006.

Russell, in the hope you see this I've added you to the group ESRI/Eagle Support.

1 Solution

Accepted Solutions
RussellRoberts1
Esri Frequent Contributor

The issue is the date format picked for the editor tracking fields. The format is not supported in the current released version of the app but our upcoming update will pick up the format type and the download will work.

Cheers

Russ

View solution in original post

0 Kudos
8 Replies
RussellRoberts1
Esri Frequent Contributor

The issue is the date format picked for the editor tracking fields. The format is not supported in the current released version of the app but our upcoming update will pick up the format type and the download will work.

Cheers

Russ

0 Kudos
MarkPeacey2
New Contributor II

Thanks Russ. Are you able to provide a list of formats that do work at the moment. I've got it working but it would be useful for other people.

It would also be great to have an 'Analyse for Collector' button within Portal/ AGOL or something along those lines which would check the various settings and capabilities of the layers, cache and webmap, required for Collector. Kind of along the lines of what happens when you analyse a service for publishing

RussellRoberts1
Esri Frequent Contributor

With the 10.2.6 release that rolled out today all the date formats are now supported. Thank you for your suggestion and I will bring it up with the team.


CheersRuss

NadiaEvans
New Contributor II

Hello,

I'm have the same issues with the error ("Unable to construct a WebMapLayer") coming up when I try to download a map onto a Samsung device. I don't get the error when downloading onto a iphone device.

Is there something I need to check/change?

Thanks

MatthewKohberger
New Contributor III

Hi.

Our field team is getting the same error using an Android device.  I don't get the error using an old iPhone 5s.

How can we avoid this in the future? 

Thanks!

DanielKnecht
New Contributor

I am using the Android version of the Collector application and getting this same error. Has this problem been resolved or is there perhaps something I am doing incorrectly?

Thank you,

Daniel

0 Kudos
JohnWalls
New Contributor II

My team is now getting this same error on a Samsung device as well. I tested on an iPhone and didn't have this issue. A little frustrating considering it was working 2 days ago, now nothing. Any indication as to what is going on with this? 

0 Kudos
DanielleKulas
Occasional Contributor III

I have a user with a Pixel and she is getting this error when trying to download a map. All iPhone and iPad users are able to download the map just fine. Any ideas?

0 Kudos