Collector app is freezing while attempting sync

987
8
12-07-2019 03:09 PM
SteveTaylor6
Occasional Contributor

All versions of on-device or off line maps on Collector app are failing to sync.  The sync is stalling or freezing a quarter of the way thru the sync.  I have not changed anything to cause this issue.  Any news on changes esri has made to ArcGIS on-line or problems with their servers to cause this problem?

0 Kudos
8 Replies
DerekLaw
Community Moderator

Hi Steve,

  • Are you using Collector Classic or Collector for ArcGIS (Aurora)? What release version are you using?
  • Are you using iOS or Android?
  • If Android, what device?
  • Is this just a single device, or does this occur on multiple devices? If the former, have you tried on a different device?
  • What kind of data are you syncing? Was this workflow working for you before or is this a brand new workflow?
  • If using Collector for ArcGIS (Aurora), are you syncing manually or using auto-sync?

Hope this helps,

0 Kudos
SteveTaylor6
Occasional Contributor

Hi Derek

Thank you for responding. Answers to your questions below:

- Happening on Android Classic version 18.03.3 build 1033 and Apple Aurora version 19.2.0 build 2714.

- iOS 13.1.3 and Android version 9

- all devices since Saturday  (so very disruptive to Ranger and contractor work flow)

- just syncing our feature layer that we have not changed at all since publishing. The feature layer is simple with one pick list or domain for the plant species.

- manual sync on Aurora

Hopefully this can be resolved asap.

0 Kudos
JustinBurdette
New Contributor III

We are having the same trouble too.....The logs in collector seem to show starting the sync job over and over again and going through several steps but never finishing? 

0 Kudos
SteveTaylor6
Occasional Contributor

Yes very frustrating. This is the second sync issue caused by esri in a few months. It is very hard to get quick resolution, so very disruptive to our work flows. It also wrecks confidence of field staff in Collector app for off-line mapping.

0 Kudos
SteveTaylor6
Occasional Contributor

Syncing again now. There needs to be better monitoring of Collector app sync issues by esri and quicker resolution of problems.

0 Kudos
DerekLaw
Community Moderator

Hi Steve,

Sorry for the late reply, I was busy this past week with the some internal meetings.

I'm glad to hear your issue is resolved.

> There needs to be better monitoring ...

FYI, for future reference - this is a good resource to check if there might ArcGIS Online issues,

ArcGIS Online Health Dashboard 

Hope this helps,

0 Kudos
MarshallPayne
New Contributor III

Any resolution? We are experiencing the same thing where the sync gets to about 75%, takes forever, and dies. The data gets back to the server but sync crashes in Collector before the confirmation so it thinks it needs to sync again.  After stripping the app and data down to nothing its still happening an the only way we are able to work around the problem is to enable Delete, which we don't want to do.  We don't want users to accidentally delete features, just update attributes.  Any ideas?   Using 10.6 and the latest Collector (iOS).

0 Kudos
DerekLaw
Community Moderator

Hi Marshall,

Please contact esri Tech Support so they can help investigate your issue further.

0 Kudos