Collector App (iOS) crashing

2148
5
03-13-2014 07:04 PM
LeehuLoon
New Contributor
I just set up a map to use on the Collector App and when I try to add a new feature the fields that I set up do show up. However when I select the first field to add text the app crashes. All the other features work and allow me to add text or a date or short integers. Any ideas why the app crashes?
Tags (2)
0 Kudos
5 Replies
RussellRoberts1
Esri Frequent Contributor
Can you share the web map and service with some and I can take a look at what may be causing the crash.

Thanks
Russ
0 Kudos
LeehuLoon
New Contributor
Hello Russ:
Here is the web map...
http://bit.ly/NdDr8f

And here is the link to the service...
http://bit.ly/NdDDVh

Also, I had the same crash on another iOS device. Both iPhone 5s.

Thanks!
0 Kudos
RussellRoberts1
Esri Frequent Contributor
Got them. Thanks! I will update this thread when I see what the issue could be.

Russ
0 Kudos
RussellRoberts1
Esri Frequent Contributor
It looks like you are using a Unique Renderer set up on a field that has no values and when you try to use that field in the popup it is causing a crash. If you use a simple renderer which mirrors exactly what you would be using in the UV setup the app works correctly. If you want to try it out you can create a copy of the test service I made just follow these steps:

1) Go to ArcGIS.com and open your "My Content"
2)Click Create Layer
3)Use the option "From an existing URL" and put this in the text box - http://services.arcgis.com/dkFz166a8Pp3vBsS/arcgis/rest/services/Norman_Campus_Tree_Inventory_forums...
4)Go through the publishing wizard and you will create a copy of the service

Then you can add this template service to a map and do data collection on it and you shouldn't see a crash anymore.

Russ
0 Kudos
LeehuLoon
New Contributor
Hello Russ:
Yes, it works perfectly now.
Thanks very much for your help!
0 Kudos