10.2.2 Server SQL2008R2 and Archiving Issues

4578
5
Jump to solution
05-08-2014 07:38 PM
PeterTimmers
Occasional Contributor III
Hi All,

Is anyone else having trouble with archiving for offline? 

I'm getting the following...

"Incorrect syntax near ')' ???

Error executing tool.: ErrorMsg@SyncGPService:{"code":500,"description":"Failed to synchronize."} Failed to execute (Sync Feature Service Replica).

Error: Failed to export data changes to replica.

Failed in acquiring Archive Difference Cursor for Dataset: GISPDB.GISADMIN.MOB_AGM_Recon for Replica: GISADMIN.Ags_Fs_1399593325880 [GUID: F2ABEC6D-BFDC-4D5F-A288-18BBAA050414]. Time taken: 0.022000 seconds. Underlying DBMS error [[Microsoft][SQL Server Native Client 10.0][SQL Server]Incorrect syntax near ')'.] [GISPDB.GISADMIN.MOB_AGM_Recon]
Tags (2)
0 Kudos
1 Solution

Accepted Solutions
RussellRoberts1
Esri Frequent Contributor
Yup if you are using an ArcGIS Server 10.2.2 it is recommended that the underlying SDE be running 10.2.2 as well. If you are using a 10.1 SDE it will be using versioned archiving and that will only support sync download.

Russ

View solution in original post

5 Replies
RussellRoberts1
Esri Frequent Contributor
I haven't seen that error before and have passed it along to the Service team. If possible it would be good to maybe log a support incident and see if this issue can be looked into further.

Russ
0 Kudos
PeterTimmers
Occasional Contributor III
Can I confirm whether you need SDE 10.2?  Will SDE 10.1 work?  Because maybe that's my issue.
0 Kudos
RussellRoberts1
Esri Frequent Contributor
Yup if you are using an ArcGIS Server 10.2.2 it is recommended that the underlying SDE be running 10.2.2 as well. If you are using a 10.1 SDE it will be using versioned archiving and that will only support sync download.

Russ
PeterTimmers
Occasional Contributor III
Yes, thanks Russ.  It does say that in the doco below but I had to read 4 or 5 times because of the link with versioning.

At first I thought you had to have versioning and 10.1 was OK for editing but it's really the opposite.  Versioning is only OK for non-editable data.

http://resources.arcgis.com/en/help/main/10.2/index.html#//0154000006m1000000

Now I've just got to upgrade production SDE :\
PeterTimmers
Occasional Contributor III
Found the problem.

You can't use SQL Geography Types for offline Collector (Haven't tried SQL Geometry but I wouldn't be surprised if it doesn't also work).

Create whole new DB with SDE10.2.2 to find the same error. Created a new feature class with same fields and SDE binary and it works.

We use SQL Geography on triggers to do intersections with other featureclasses to fill fields post collection.  

Now we have no shortage of SDE 10.2.2s... :\
0 Kudos