Transparent Inner Lot

1090
5
12-06-2016 03:54 PM
AndrewKamin-Lyndgaard
New Contributor

I'm new to C.E. and CGA but have been immersed for last few days in order to generate a cityscape for an important presentation. C.E. could be a time saver provided I don't get hung up on to many little things.....such as...

I've using the schematic city.cga to propegate geometry into a custom designed landscape with elevation. In evaluating the CSA code I can't figure out why the floor (ground plane) of my blocks are transparent. They are clear in teh CE viewport but when exported there is no geometry.

Any clues appreciated?

0 Kudos
5 Replies
DanPatterson_Retired
MVP Esteemed Contributor
0 Kudos
LR
by
Regular Contributor

Post the rule?

0 Kudos
DavidWasserman
Regular Contributor

Are you looking at the floors from above or below? Both? It could be a face culling issue. 
What happen in the CE scene when you toggle Back face culling on and off? 

http://cehelp.esri.com/help/index.jsp?topic=/com.procedural.cityengine.help/html/manual/ui/vw/vmodes... 

David Wasserman, AICP
0 Kudos
AndrewKamin-Lyndgaard
New Contributor

Gang-

Thanks for leaning into my inquiry. Still stumped and frustated by my work arounds thus far.

L.R. I have attached the .cga file. Thanks in advance for taking a look.

David-  The back face culling does toggle on/off the visibility of assets....except those generated with the schematic_city.cga rule. Reference pic.

The lack of texture on the building geometry is preferred in this instance but would ideally be able to select from 3-4 ground plane (LotInner) options via the script. Reference creative direction below.

Again...grateful to support of ESRI community.

0 Kudos
LR
by
Regular Contributor

Unless I'm not understanding what you're trying to do it seems that you're generating buildings on lots and leaving the area around them blank/NIL. What's visible in CE is the shape underneath, which isn't displayed in the webscene. Try replacing..

@StartRule
Lot -->

with

@Color
attr GroundColor = "#FF0000"

@StartRule
Lot -->
 ColorGround
 LotCase

ColorGround --> color(GroundColor)

LotCase -->‍‍‍‍‍‍‍‍‍‍

You can hide shapes by hitting F11 while the viewport is active.

0 Kudos