ShapeL, shapeU and shapeO doesn't work

670
2
01-07-2013 01:46 AM
anthonymagdelaine
New Contributor
Hi,
i would like to use shape for my building, but don't know why it only does cubes shape instead of L, U or O shapes.

maybe wrong way i used it i paste my code:

version "2010.3"
attr Bat_Height = rand(15,30)
attr CoursSize = rand(-5,-20)
attr BatVar = rand(5,30)

Lot-->offset(-0.5)Global
Global-->comp(f) { border : Murs |inside : Cours }
Cours-->offset(CoursSize)CoursComp
CoursComp-->comp(f) { border : CoursRecre | 
      inside : CompLycee}
CompLycee-->shapeL(BatVar,BatVar) { shape : extrude(Bat_Height)FormComp | 
           remainder : CoursRecre}

//extrude(Bat_Height)FormComp
FormComp-->comp(f) { front : Entree|
     streetSide : CoteFenetre | 
     noStreetSide : CoteCours | 
     top : Toit }
     
CoteCours-->color("#FF0000") 
CoteFenetre-->color("#FFFF00")
Entree--> color("#00FFFF")
Murs-->comp(f) { front : MurEntree| 
    side : MursFerme }
MurEntree-->split(x) { 3 : Shape }*
MursFerme-->extrude(3)

CoursRecre-->setupProjection(0, scope.xy, 1, 1)
    projectUV(0)
    texture("images/Textures/Roads/Asphalt.jpg")
0 Kudos
2 Replies
JoanneO_Brien
Occasional Contributor
I think your issue is in this section :
CoursComp-->comp(f) { border : CoursRecre | inside : CompLycee}


I'm not 100% sure the best way to correct this but I was wondering why you don't just use setbacks for the different sides? Might work out easier rather than multiple component functions as I think it's getting confused within it.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi !

I'm pretty sure the issue is the following :

shapeLOU() and setback() all need the scope to be aligned yUp. After a comp(f) {}, the scope is aligned zUp, so this will not directly work.

-->
use e.g. 'alignScopeToGeometry(yUp, 0)' to make this work.

Ok ?
0 Kudos