Scene Layer ordering

569
9
06-19-2017 05:52 AM
Luiz_AmadeuCoutinho
Occasional Contributor III

Hi

In CityEngine Scene Layers my layers are on the correct order, but when are exported to Webscene CityEngine put the layers randomly. There´s a mix of Static Models, Basemap, Shapes....

Maybe is a basic question but I don know how to fix it.

Tags (1)
0 Kudos
9 Replies
CherylLau
Esri Regular Contributor

That's strange.  I can't seem to reproduce it.  The layers are all in the correct order if I follow the steps to export the scene in Tutorial 15 (Help -> Download Tutorials and Examples).  Does this tutorial work for you?

Tutorial 15: Publish web scenes—CityEngine Tutorials | ArcGIS Desktop 

I noticed that there's an asterix in the Scene tab which means that the scene has not been saved.  Does saving the scene help?  The exporter should export the scene with the changes even if the scene is not saved, but it would be interesting to know if this helps or not.

0 Kudos
Luiz_AmadeuCoutinho
Occasional Contributor III

Hi Cheryl

I know it´s tottaly weird.

The scene was saved before export, but still doing the same . Check the prints, please. I´m not using any previous  export Settings. 😞

0 Kudos
CherylLau
Esri Regular Contributor

Did Tutorial 15 work for you?

I noticed you are using version 2015.2.  You could try upgrading to 2016.1, but I don't think it should make a difference in this case since exporting Tutorial 15 with 2015.2 also worked for me.

0 Kudos
Luiz_AmadeuCoutinho
Occasional Contributor III

I did the Tutorial 15 and worked very well.

Crazy isn´t?

0 Kudos
CherylLau
Esri Regular Contributor

I can't see why this doesn't work.  Can you think of something that might be different about your scene compared to tutorial 15?  Would you be able to post your scene?

0 Kudos
Luiz_AmadeuCoutinho
Occasional Contributor III

I´m trying to compare with Tutorial 15, I can´t see anything special.

Here my scene : http://bit.ly/2sSEu7n 

Thank you for the support

0 Kudos
CherylLau
Esri Regular Contributor

Sorry, I meant the CityEngine project.

0 Kudos
Luiz_AmadeuCoutinho
Occasional Contributor III

Hi Cheryl

I can´t share the project.

0 Kudos
Luiz_AmadeuCoutinho
Occasional Contributor III

I found one "solution" .

My Cityengine was upgraded to 2016.1

Solution: Create a new project and import the layers and models ordering the first(the layer that you want to show on top of the webscene) to the last.

I mean:

Addind to ViewPort

Layer 1

Layer 2

Layer 3...

...

Basemap(the last one)

and publish.

On export models per layer will show the sequencial order that you added(The older first-Layer 1 and the newer last - Basemap).

The problem: If I want to change the order again I must to create a new project and restart the process.

Here my new Webscene updated: http://bit.ly/2toSd5U 

0 Kudos