Incorrect model orientation in exported FBX model

2567
6
07-24-2012 08:15 AM
KristinBlier
New Contributor III
I'm trying to export a collection of assets. The scene coordinate system is a UTM projection. I want the vertices of the exported model to be relative to the model center. That is working appropriately. The problem is the model orientation. The coordinate axis in CityEngine shows the models as oriented z-up. However, when I use the FBX exporter, the resulting model is oriented y-up.

Are there any settings available to work around this?
0 Kudos
6 Replies
MatthiasBuehler1
Frequent Contributor II
hey !

Sorry for the late reply, I've been in holidays.

CityEngine shows the coordinate system as zUp in the HUD in the viewport, that is correct. Though, this is only visualizing the values zUp if you're working with GIS data (GIS people work with xy, z being the height). CityEngine actually works yUp internally.

But that is also stored in FBX, so if you import the file into your other 3d application, you should have easy import options to have the vertices converted for you.

Hope this helps !
0 Kudos
BenLeslie1
Regular Contributor
Any plans to give us the option of using "proper" x-east, y-north, z-up axis orientation in future releases.  After all, you're an ESRI product now it would seem logical - I find this this y-up, negative-z stuff is quite confusing.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi Ben,

This functionality is already in there. Check out the 'Navigation Display' Settings in the viewport settings menu.

Toggle the 'Navigation Display' with d,n.
Also, toggle the 'Axes' with d,a.
And the compass with d,c.


But of course, we're open for inputs. If you miss anything specific, let me know...

Matt
0 Kudos
BenLeslie1
Regular Contributor
Hi Matt - this is kind of my point about it being confusing......unless I'm missing something...

So I turn on the axes - which shows Z-up.  However if I draw a shape and translate it in the z-direction it does not move up, it moves in the north-south axis - I have to translate it in y-direction to move it up.

But my big problem is with exports being oriented with y-up because this doesn't match my other data - so I was asking if there could be an option to have the whole environment (import, working and export) oriented with z-up.

I wonder if there are any nice bits of python that could fix this for me - or should I ask this on the python forum?
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi,

ok, I better understand your confusion now.


Changing yUp to zUp 'as a whole' in CityEngine is currently not possible. CityEngine works and stores everything in cartesian coordinates, in yUp. That's the way it was designed and that won't change in CityEngine soon.

So since you have GIS data, you may not know that in ArcGIS 10.2, we provided a GP tool to have the geometries created directly in ArcScene (no import in CE > Generate > Export to ArcScene). So that may be an alternative to work entirely in zUp. Though there's a hotfix needed for 10.2 and CityEngine 2013 to actually create the RPKs ( Rule Packages ) to feed to the GP tool. So that's upcoming. Also, the GP tool is really stripped down in it's interface (only 1 start rule allowed, no attr changes possible to run the tool. This was done for simplicity, though I doubt it was a good decision.)

So this means for you, it's best to just 'think' anything in y being height and xz being the horizontal plane. ALL the tools inside CityEngine work that way, ONLY the Navigation Display shows a 'live recalculated' info status in a standard zUp GIS way.

> Currently no way around this.

Let me know if you need more details / inputs !

Matt
0 Kudos
BenLeslie1
Regular Contributor
ahh sounds promising - we're due to update our arcGIS and CE licences soon.  Looking forward to it.

Thaaaaanks
0 Kudos