Import problem (Coordinates)

2334
8
03-13-2013 11:00 AM
LukeCzar
New Contributor III
Hi Matthias!

I also have a lot of problems with coordinates, the model is far away from the scene - but in this case I do not care about coordinates, it just doesn't matter, so I want to import my model into a scene, but "because of coordinates" the model is too far from the scene, it says I can just drag and drop the model in order to place it where the cursor is, but still I get the same message

Is there any way to turn off coordinates?

[ATTACH=CONFIG]22585[/ATTACH]


Lukasz
0 Kudos
8 Replies
MatthiasBuehler1
Frequent Contributor II
Hi.

Usually you work entirely with geolocated data ( coordinates far away from the cartesian origin ) or without ( near the cartesian origin ).

You can not work with both at the same time. This is a measure of caution to prevent export precision issues. So either you georeference your import data or move your existing data back to the origin.

You could also do this trick :
Create an obj or collada asset from the data you want to import, then drag and drop it into the viewport as a 'Static Model'. Then use RMB > Convert Model to Shapes.

> Check the coordinate values in your data. E.g. if your dxf has very high coordinate values, the data is geolocated. Maybe synch this in your CAD app even before import in CE if you don't care about georeferenced stuff.

Ok ? Let me know ..

Matt
0 Kudos
LukeCzar
New Contributor III
So I created the rule that imports objects "i("object.dae") and it worked out.
I was going to bring collada file as "terrain" , but I wouldn't be able to adjust other object into terrain, so I will have to figure out something else, it would be nice to have an option to adjust 2 selected object into themselves,


Thanks!!!!


Lukasz
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi ..

Only bitmap based terrains are supported, no mesh based terrains.

Sorry ..

m.
0 Kudos
NicoleHanson
New Contributor III
Hey Matt-

I'm having a similar problem, but I went through and made sure that both my shapefile and the raster/tif files have the excat same projection.  But it doesn't matter which one I bring into CE first, I still get the same error message that it's to far from the current scene's contents. 

Help!

Nicole
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi Nicole.

Then I assume that your shapefile data contains large coordinate values ( xy values with z height component ) and not (lat / long values). That way, the huge values are interpreted as lat / long coordinates, which is indeed far away.

Thus, export your data specifically unprojected ( non-cartesian lat / long values ) for import in CE. in most cases, a shape file contains projected xyz coordinates, with the .prj file just indicating from which projection system the data was exported from.

Hope this help...

M.
0 Kudos
NicoleHanson
New Contributor III
Hi Nicole.

Then I assume that your shapefile data contains large coordinate values ( xy values with z height component ) and not (lat / long values). That way, the huge values are interpreted as lat / long coordinates, which is indeed far away.

Thus, export your data specifically unprojected ( non-cartesian lat / long values ) for import in CE. in most cases, a shape file contains projected xyz coordinates, with the .prj file just indicating from which projection system the data was exported from.

Hope this help...

M.


How do I export it with no projection?
0 Kudos
MatthiasBuehler1
Frequent Contributor II
I'm no expert in GIS, but maybe there's a PRO here who can help with this specifically.


I'd try to track this down and check what the coordinates are which you write out. E.g. open a test shp file in a text editor.

If the values are between 0 and 90 ( e.g. 20.234234 / 42.234234), they're in degrees, so not projected.
If the values are very large ( e.g. 534'034.892348 / 5'038'474.83473764 ), they're in cartesian coordinates, so projected ( in a specific projection ).

Mathematically seen, the geolocation is 'equal'.

Maybe it's best to export all your data the same way and build the scene file from scratch. That way you don't have to think about how to export different datasets each time.

m.
0 Kudos
NicoleHanson
New Contributor III
Ok, Thanks!
0 Kudos