Image transparency in CE web viewer from ArcScene

494
3
06-11-2014 12:34 PM
StuartPidgeon
New Contributor
Hi there

I'm not sure what I'm doing wrong here, but maybe someone can help.  In ArcScene I have a jpeg orthophoto tile draped over a TIN, and I apply transparency to in order to make underground features partially visible from above.  Every time I export to a 3D web scene though the transparency is lost.  I've tried all of the following:

- different values for the transparency % setting
- reduce the resolution of the aerial photo
- convert the image to png with an added alpha band so the transparency is built into the image

In all cases, the transparency is lost in the CE web scene.  The white paper about exporting to CE web scene from ArcScene seems to suggest that transparency is supported, although perhaps this is only for textures on 3D objects? 

Any suggestions would be greatly appreciated.  I'm using 10.2 with the patch applied, and have also tried on a different machine running 10.2.2 with the same results.
0 Kudos
3 Replies
MatthiasBuehler1
Frequent Contributor II
Hi,

just to be sure, you're using the GP tool, right ?

m.
0 Kudos
StuartPidgeon
New Contributor
Hi Matthias

Thanks for the quick response.  Yes, I'm using the GP tool.  Interestingly the same day I posted this I finally managed to get transparency to hold in the web scene, although I'm not completely sure why.  One difference I could tell was that this time I was using a TIN in ArcScene that was exactly clipped to the same extents as the image, whereas previously the TIN the image was draped on had been of a larger coverage area.  I'd still like to be sure exactly what is needed to get raster transparency to hold in the web scene, but at least of got one ArcScene sxd where it works.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi,


okay.

for CityEngine terrains, the extents of the elevation map and texture map must match. Thus, I assume this is also true if you create WebScenes from ArcScene.

please keep an eye on this and let me know if you have more issues.


matt
0 Kudos