CityEngine2015 - error message - please help

2819
2
Jump to solution
07-09-2015 09:09 AM
SchSch
by
New Contributor II

Hello,

I use the program CityEngine2015.1, but I have got a problem. When I import a *.jpg or *.png file (example in the Tutorial_02_Terrain_and_Dynamic_City_Layouts, obstacles and topo files) the program is closed and I find an error message on the desktop:

#

# A fatal error has been detected by the Java Runtime Environment:

#

#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000001634dd02, pid=2648, tid=4052

#

# JRE version: Java(TM) SE Runtime Environment (7.0_71-b14) (build 1.7.0_71-b14)

# Java VM: Java HotSpot(TM) 64-Bit Server VM (24.71-b01 mixed mode windows-amd64 compressed oops)

# Problematic frame:

# C  [ig4icd64.dll+0xbdd02]

#

# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows

#

# If you would like to submit a bug report, please visit:

#   http://bugreport.sun.com/bugreport/crash.jsp

# The crash happened outside the Java Virtual Machine in native code.

# See problematic frame for where to report the bug.

#

...

What's the problem exactly? It's very important for me, because I cannot use CE especially by rasters and I tried to install a lot of Java versions.

More informations:

Win 8.1 64 bit

4.00GB memory

Intel(R) Pentium(R) CPU P6100 @ 2.00GHz (2 CPUs), ~2.0GHz

Intel(R) HD Graphics

Is an error message about Java or about hardware-problem, too?

It's very urgent for me, I'm waiting for the answers and thanks a lot!!

BR

Aletta

0 Kudos
1 Solution

Accepted Solutions
Matthias_Specht
Esri Contributor

Hi Aletta,

I see you are running CityEngine on a Intel integrated graphics board. That is not officially supported, we recommend to use dedicated NVIDIA ort ATI Graphics boards.

However, there is chance you get CityEngine running on your graphics card.

Your error message basically says CityEngine crashed in the Intel graphics driver, and I understand you think it's connected to rendering some images.

I suggest the following:

1. make sure you have the latest graphics driver

2. if it still crashes, try enabling Preferences/General/Procedural Runtime/Rendering => "Disable GL Mipmaps" and/or "Disable GLTexture Compression".

If you still experience crashes, can you please explain in detail what you mean with "When I import a *.jpg or *.png file" - do you view it in the asset inspector, are you using it with the texturing tool or are you writing cga rules which use the texture?

Also, if the crashes persist, could you please provide me the full error message?

regards

Matthias

View solution in original post

2 Replies
Matthias_Specht
Esri Contributor

Hi Aletta,

I see you are running CityEngine on a Intel integrated graphics board. That is not officially supported, we recommend to use dedicated NVIDIA ort ATI Graphics boards.

However, there is chance you get CityEngine running on your graphics card.

Your error message basically says CityEngine crashed in the Intel graphics driver, and I understand you think it's connected to rendering some images.

I suggest the following:

1. make sure you have the latest graphics driver

2. if it still crashes, try enabling Preferences/General/Procedural Runtime/Rendering => "Disable GL Mipmaps" and/or "Disable GLTexture Compression".

If you still experience crashes, can you please explain in detail what you mean with "When I import a *.jpg or *.png file" - do you view it in the asset inspector, are you using it with the texturing tool or are you writing cga rules which use the texture?

Also, if the crashes persist, could you please provide me the full error message?

regards

Matthias

SchSch
by
New Contributor II

Hello Matthias,

Thanks a lot for your help!

The program CE cannot run on my computer on account of my graphics card, as you wrote it in detail. I have the latest graphics driver and I have access to the funkcion/s ""Disable GL Mipmaps" and/or "Disable GLTexture Compression", but I got unfortunately the error messages.

The problem happens for example I drag and drop an image file into to Viewport to create a terrain, or use a texture on a building, also when I would like to work with a raster.

Moreover I cannot use several *.cej from scene, which are included in the Tutorials.

The graphics card doesn't allow / will not be possible the program to operate, so this is a problem of hardware.

I work on it, there are maybe other solutions to solve the problem.

BR

Aletta

0 Kudos