CityEngine Scenes

2806
2
12-07-2014 01:15 PM
EmmaKirkpatrick1
New Contributor

In CityEngine 2014 I was able to easily save and reopen scenes that I had created. However, I tried opening a scene made in version 2014 and it would not work in version 2012. Has anyone come across this issue?

Tags (1)
0 Kudos
2 Replies
by Anonymous User
Not applicable

This is always the case. CityEngine scenes (.cej files) do not attempt to be "forward compatible", so a scene created in 2014 will not work in 2012. The majority of applications and formats are not forward compatible - here is more info about this, in general: Forward compatibility - Wikipedia, the free encyclopedia

However, many CGA rules will work in earlier versions - just change the version number in the CGA back to the version you are working with. If you see compiler errors, then you may be using newer elements of CGA, which are unknown to the earlier compiler.

But the main idea is that a scene developed in a newer version of CityEngine will not open in earlier versions.

EmmaKirkpatrick1
New Contributor

Thanks for your help!

0 Kudos