Select to view content in your preferred language

CityEngine not responding when opening a new scene

1138
10
Jump to solution
08-11-2023 06:24 AM
CarlBesterEsriZA
New Contributor II

After a couple of years, I recently installed CityEngine 2022.1 to get back into it, but every time I try to open a new scene the entire CE application becomes Not Responding. 

I remember in an earlier version it did something similar but can't seem to find the post.

Any suggestions will be appreciated.

CarlBesterEsriZA_0-1691760226111.png

 

0 Kudos
1 Solution

Accepted Solutions
SimonHaegler
Esri Contributor

The first thing I noticed is this message:

"The Service NahimicService was detected on your system. Resizing CityEngine windows can lead to crashes when this service is active. Please deactivate the service or if that is impossible add the following line to the CityEngine.ini in your CityEngine installation: '-Dglsinglebuffer'. This activates single buffering and can lead to degraded rendering performance."

Please try to disable the NahimicService - or if you need it, edit the CityEngine.ini file (in the CityEngine installation directory) and add a line with "-Dglsinglebuffer" (without the quotes).

Best,
Simon

View solution in original post

0 Kudos
10 Replies
SimonHaegler
Esri Contributor

Do you have other CityEngine versions installed which start correctly?

The screenshot looks like it fails while open the 3d viewport - what GPU do you have?

Best,
Simon

0 Kudos
CarlBesterEsriZA
New Contributor II

Hi Simon,

Thank you for the response. Yes that is exactly what happens. Every time I try to open a 3D viewport it falls over.

I have uninstalled all previous versions of CityEngine. GPU Specs are below:

CarlBesterEsriZA_0-1692090648955.png

Is there a setting somewhere in the CE preferences where I can make sure it is using the right GPU?

Thanks,

Carl

 

 

0 Kudos
SimonHaegler
Esri Contributor

Hi Carl,

I see you have fairly modern GPU hardware. While CityEngine should also run on the integrated UHD graphics, let's try to force it to the Nvidia GPU.

Here's one guideline how to do this: https://youtu.be/YCqW_5HI_v4

Best,
Simon

0 Kudos
CarlBesterEsriZA
New Contributor II

Hi Simon,

I have applied the settings as per the video....unfortunately still no luck. Any other ideas?

Would there be error logs that I can go and dig for?

Regards,

Carl

 

0 Kudos
SimonHaegler
Esri Contributor

From your original post I understand that you can start CityEngine and you see the welcome screen.

If this is correct, then you can go to Window -> Log menu item and see if there are any warnings/error entries. Entries separated with a dashed line mark restarts of CityEngine. The first button allows you to export the log, please attach it here.

Best,
Simon

0 Kudos
CarlBesterEsriZA
New Contributor II

Yes that is correct. 

It only hangs when I try to open the 3D Viewport.

Thanks,

Carl

 

0 Kudos
SimonHaegler
Esri Contributor

The first thing I noticed is this message:

"The Service NahimicService was detected on your system. Resizing CityEngine windows can lead to crashes when this service is active. Please deactivate the service or if that is impossible add the following line to the CityEngine.ini in your CityEngine installation: '-Dglsinglebuffer'. This activates single buffering and can lead to degraded rendering performance."

Please try to disable the NahimicService - or if you need it, edit the CityEngine.ini file (in the CityEngine installation directory) and add a line with "-Dglsinglebuffer" (without the quotes).

Best,
Simon

0 Kudos
CarlBesterEsriZA
New Contributor II

Hi Simon,

I found the "Resizing CityEngine windows..." part interesting because I had CE open on my second monitor. I then reopened CE on my smaller (main) monitor before opening the viewport and it worked. 

 

CarlBesterEsriZA_0-1692177979361.png

 

I then moved the CE application to the secondary monitor and could continue opening new 3D viewports. 

I tested closing and reopening CE on the secondary monitor and it crashed again.

It looks like as long as the first viewport I open is on my main monitor (that of my laptop), I can move the app to the larger screen and continue opening new viewports.

It sounds crazy I know...but at least I can get it working. Have you ever come across a similar issue?

Thanks,

Carl 

0 Kudos
SimonHaegler
Esri Contributor

I'm glad you found a workaround.

While there could be a bug in our multi-monitor handling I would be curious to see if applying "-Dglsinglebuffer" or disabling the NahimicService fixes the problem altogether?

Best,
Simon

0 Kudos